Download

Unreal Engine Editor does not start any more

Unreal Engine Editor 4.27.2 suddenly does not start any more. A couple of days ago everything worked.
Now when I click launch I see the running process but do not see any UI at all. If I click launch again, I see one more process, etc.
Already tried to run as an Administrator, complete reinstallation, rolled back last Windows update, disabled Antivirus, updated Nvidia drivers - nothing helps.
Also, I cannot find any logs. The folder “Saved” simply does not exist.
My laptop is:
Windows 10 21H2, 16GB RAM
GPU Nvidia Quadro T1000 with 4GB.
Everything worked perfectly until today :frowning:

Is there a way to enable UE editor logging to understand the reason?

Any help greatly appreciated.

UPDATE:
Only was able to get some logs when tried manually launch C:\Program Files\Epic Games\UE_4.27\Engine\Binaries\Win32\UE4Game.exe:
[2021.12.15-20.25.24:639][ 0]LogShaderLibrary: Display: Running without a pakfile and did not find a monolithic library ‘Global’ - attempting disk search for its chunks
[2021.12.15-20.25.24:639][ 0]LogShaderLibrary: Display: … not found
[2021.12.15-20.25.24:680][ 0]LogShaderLibrary: Error: Failed to initialize ShaderCodeLibrary required by the project because part of the Global shader library is missing from …/…/…/Engine/Content/.
[2021.12.15-20.25.49:843][ 0]LogWindows: FPlatformMisc::RequestExit(1)
[2021.12.15-20.25.49:843][ 0]LogWindows: FPlatformMisc::RequestExitWithStatus(1, 0)
[2021.12.15-20.25.49:843][ 0]LogCore: Engine exit requested (reason: Win RequestExit)
[2021.12.15-20.25.49:849][ 0]Log file closed, 12/15/21 21:25:49

When launch UEEditor from EpicGames launcher or via shortcut - nothing happens.

Found the reason of this issue - Windows Defender Firewall!
After connecting to different network in the office and launching UE4Editor, suddenly a Windows Firewall window appeared asking about access permission. After the grant, it started to work :slight_smile: . When I returned home, it continued to work. But today it stopped to work again. So I disabled the Firewall and everything started to work again!
Looks like UE4 has some issues with Windows Firewall and it depends on some Internet requests before starting, and if such requests are blocked it just hangs without any errors and logs :frowning: .