Unreal Engine Editor Crashed How can I resolve?


I have been learning a lot with Unreal Engine and has been an amazing engine to work with but this is the first huge problem I have that has been unsolvable for the past few days. I opened up my project only to find that it would crash every time at 45%. I can’t find anyone who has the same issues I am having in the crash window. Everyone has different’ errors as to why they crashed. Attached to this question is a screenshot of my Crash Log.

Any help is appreciated.

Thank you

I was trying to login to post the question and it posted it without letting me add the photo. Here is the photo to my question.

I just tried a black project and it worked! However this other project has so much time and work put into it and I’d love to get it working again. Thanks for replying!

a new blank project also, or only one project which suddently stopped working?

the other project is not lost - but can be fiddely to find the (most of the time) ONE asset which brings your Editor to crash. check the logs in the “Saved\Logs” subfolder of your project if it says something meaningful or upload your log here.

if not, I would suggest following steps:

  1. duplicate your project folder as a backup
  2. delete saved, intermediate, build folders (mostly all except Config/Content/Source/)
  3. try to load your project - if it works good :wink: if not continue
  4. open your .uproject file and remove the plugins and modules you may have setup, check if it loads, if not
  5. go to content folder, search for all files in (sub-)folders, eg: in windows explorer search bar enter a dot (".") which will give you all files
  6. order by modified date and start deleting the ones, recently modified (remember - step 1 :slight_smile: )
  7. try to load your project
  8. if it doesn’t work, goto step 6

I was able to open up the logs and below you will find where I see the errors at the top of the log.
So what I understand is it could be an asset that is causing this crash correct?

Log file open, 09/10/19 14:02:37
LogWindows: Failed to load ‘aqProf.dll’ (GetLastError=126)
LogWindows: File ‘aqProf.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi32e.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi32e.dll’ does not exist
LogConsoleResponse: Display: Failed to find resolution value strings in scalability ini. Falling back to default.
LogInit: Display: Running engine for game: ArchExploit
LogPakFile: Registered encryption key ‘00000000000000000000000000000000’: 0 pak files mounted, 0 remain pending
LogPlatformFile: Not using cached read wrapper
LogTaskGraph: Started task graph with 5 named threads and 26 total threads with 3 sets of task threads.
LogStats: Stats thread started at 0.340017
LogD3D11RHI: Loaded GFSDK_Aftermath_Lib.x64.dll
LogICUInternationalization: ICU TimeZone Detection - Raw Offset: -5:00, Platform Override: ‘’

yes, it could be an asset, or a config setting, or a plugin, … Thats why I suggest start deleting them in the order you’ve last modified / added them. Maybe also start with the default map your editor should load. Or start copying into your new blank project (starting with the config) and see if that starts crashing as well. In the log entries I can’t read any useful.
also try deleting the content of C:/Users/{system username}/AppData/Local/UnrealEngine

is it a c++ project or blueprint only (do you have a source folder)?

It is a Blueprint project. And ok I’ll give it a try and start deleting assets in the contents folder. Would the source folder be the contents folder?

no, the source folder is in the project root. if it is a blueprint only project, you don’t have one (its c++ files). I know it is cumbersome, but this is the only way I’ve recovered all my projects. it happened to me quite a lot. start using SCM like git or svn - this will save you in the future as you can go just back to a revision which works. maybe start with deleting/renaming the Config folder and try to open it. then continue with assets in Content/ - and remember the backup :slight_smile:

Hello Adnoh, so I started following the steps above and it opened up and then crashed. So I started deleting assets one by one and opening it up and it went back to crashing, this time at 50%. I was getting nowhere so I deleted almost all the assets and it still crashed at 50%. Do you have another idea as to why may work? Thanks!

I also found this in the crash window as well I thought it might be helpful I hope!
Assertion failed: InPos <= Size [File:D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\HAL\FileManagerGeneric.cpp] [Line: 655]

You created a new Project with Same ue Version which does Not Crash? Try moving your assets Into that new Project. Mostly i would say it is a map or config setting.

Hello Adnoh, so after moving the files over to the new project the new project stopped working and showed me the same crash error the moment the files were important into the new project.

Hello Adnoh,

I resolved the issue. I took a lot of time to look at the logs and while it was extremely difficult to understand, I found there was a file that was causing the issue from the assets. I eventually found the name of that file within the crash logs and simply removed it. Unfortunately I don’t know the reason the file was causing the crash so I’ll have to start that map from scratch again. But this was the way I resolved my crashing issue by reading the logs and researching which file was corrupt or just not working.

Hi NewRewind. Good to hear it worked and at least Not everything went south. I know IT IS Not easy and timeconsuming. Maybe you have a Backup under /Saved Folder? The engine Puts There autosaves and sometimes older Versions of Files when you Hit the save Button. You should use a SCM Like Git in the Future :wink: