Unreal Engine doesn't support AI movement over simple hills.

Does anyone know when this feature will be added? I have the top down template open and navmesh doesn’t get generated on simple terrain hills.


1 Like

It’s not a missing feature, in fact the above holes are as a result of one of the many features! There is a configuration parameter determining the maximum slope you want your agent to be able to walk on.

Can you point me to any tutorial that shows how to simply configure the nav mesh to cover basic hills?

I’ve been experimenting with the recastnavmesh settings and I just can’t get the navmesh to cover a simple hill.

Don’t know of any tutorials, but I’d suggest:

  • Make sure your bounds volume is big enough
  • Try increasing AgentMaxSlope and AgentMaxStepHeight
  • Cell Size and Cell Height might need to be reduced if your terrain is sharply varying

Also, be aware that an actual hole in the navmesh is drawn with a border. You’ll often get what look like holes in the green visualization, that are in fact just a case of the green mesh sometimes going underneath the ground mesh. You can avoid this by increasing the Draw Offset property.

I added a more thorough tutorial here.

1 Like

This was super useful Thanks :smiley:

**Don’t forget to ONLY change navigation mesh under project settings → navigation mesh. **

The nav mesh generation is working fine, you just need to configure the right settings. Just remember that your AI will take the shortest path, even if that means walking around the hills.

Do not listen to this guy. It is not that easy, he lies.

I assure you I have gotten AI to walk all over a very large & steep (8km x 8km) landscape by just changing the max walk slope for the nav mesh.

Thanks for sharing all your valuable information.

I added a more thorough tutorial here.

I can’t tell whether or not you are being sarcastic, but your link is broken :confused: