Unreal engine distorts material textures from far away

I’m not sure what’s wrong, and I wanted to fix this so it didn’t look bad.

It’s hard to tell what scale you’re working on there, but it looks like a reflection capture. Try removing that…

It was a default blank world, and I didn’t even have a capture. It looks somewhat like screen-door effect, but it’s distorted at certain angles.

Solved: By going into the texture (mine is 128x so I used UE4’s nearest neighbor scaling) and changing the Mip Gen Settings to NoMipmaps or LeaveExistingMaps fixed this. Although it increases screen door effect, it makes it slightly less noticable.