Unreal Engine crashes when creating a media texture asset

Hello,

I have a problem in the version 4.18.1. of the engine with the media texture assets because the engine crashes while creating this asset needed to work with media players and videos in my application. I have tried to create the media texture asset, or to create it through the media player asset checkbox. The editor crashes, does any one know how could I work with this asset or if this bug will be fixed in the following patches?

Thanks in advance.

Mike

Please include callstack and log files, otherwise we can’t help, thanks!

I’m having the same issue. The call stack and log is attached.

Thanks for the logs. Looks like this is macOS specific. We will try to repro it,

Hello ggmike1991,

After taking a look at the information provided I was able to find that this appears to be a known issue. I have provided a link to the public tracker please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-51940)

Make it a great day

Still not totally fixed in 4.18.3.
I had a Media Player system set up in UE4.18.3 the was working all the way to running it under ARKit on an iPad.
Worked for a number of weeks.

Made a change to swapping the materials out between a 2D texture material and the Video Material.
This was a feature that I had working from the start but decided to take it out.
This was when the crashing started.

I rebuilt it the way it was originally and it still crashes.
When I disable the problematic Blueprint and add a test plane set up to run video it runs including the disabled video plane because it still carries the video material correctly set up and is visible in the scene.

What is strange is that it was all working then just by making a change that simplified the set-up it starts crashing.

This is part of what is quoted in the Crash Reporter:
#0 at 0x7fff6333ee3e *** Terminating app due to uncaught exception ‘NSRangeException’, reason: ‘Cannot remove an observer for the key path “status” from because it is not registered as an observer.’

It has been claimed to be fixed in hot fix 18.3 however I am running 18.3.