Unreal Engine crashes after loading

Currently I’m having an issue, the engine freezes and then crashes after the loading.

Here is the list of things I’ve tried:

  • Clear the local appdata related to Unreal Engine;
  • Update the drivers (assuming it was a GPU problem);
  • Reinstalled same engine;
  • Used a difrent engine (version 4.20 preview 5);

It seems to be related to the GPU, the one I’m using is the NVidia Geforce 610M (1GB). Previously it worked just fine but recently it crashes almost every time, its rare that actualy opens properly.

I fixed the problem by using the intregated graphics from Intel but I wanted to use the Nvidia GPU so I can use a more powerful graphics card.

Is your project C++ or Blueprint based?

Hmm… Your graphics card is about equivalent to the recommended one on the wiki, though 1GB of RAM seems like it might be too low to me. Have you updated the engine version you’re using recently? Also have you tried checking the logs?

The project is Blueprint only, also I don’t have visual studio installed.

Hi DarkRikax.
Did you enable any plugin about PhysX in your project? Maybe your GPU has issues about that.

Or did you change ShaderModel or DirectX Version settings in ScalabilitySettings?

Try using a default file of “YOURPROJECT\Intermediate\Config\CoalescedSourceConfigs\Scalability.ini”

Or test the engine a few times with a new project.

If these are not even related, check your GPU heat when engine crashes. GPU can close itself for self-protection and change to Intel GPU automaticly. And this auto-changing can break your engine.

The engine is up to date, I’ve reinstalled the same engine about 3 times.
In the logs file the line that shows an error appears “DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG” at the end of the line, following with “Status: Timeout” and “GPU Stack Dump”.
I’m kinda new with this stuff so I don’t know exactly what I’m looking for.
link text

I usualy keep the engine with default settings, I didn’t change or intalled any plugins.

I’ve also tested creating and opening new projects, still the same result.

The GPU doesn’t heat up to much to concern about.

There’s one thing that bothers me, in the log file it shows that the driver is unknown ( Driver Version: Unknown (internal:Unknown, unified:Unknown) / Driver Date: Unknown ), It detects correctly the GPU but not the driver, I’ve tried to make a clean install of the driver but still the same result.

Is there any chance to reinstall Windows on a diffrent hdd or ssd? You need to be sure if it’s hardware problem or software problem about your GPU.

In response to what OttomanEmpire suggested, I would highly recommend against attempting to reinstall Windows in an attempt to fix this as that’s a bit of a heavy-handed approach. Those DXGI errors lead me to think something is going wrong with your GPU causing it to stall and crash the engine. Also looking at your logs, it seems as though you’re attempting to load your project from a secondary hard drive (specifically your D drive). Is it possible for you to load your project from your C drive, or is that a smaller drive dedicated solely to Windows?

Could you try the following for me and let me know what happens?

  1. Uninstall the engine.
  2. Delete all folders in your project except Config, Content, and Source (if you have it). Also do not delete the project file.
  3. Move your project to a different directory (preferably to the C drive as noted above).
  4. Reinstall the engine.
  5. Try re-opening the project.

“Error: Result failed
at **********\D3D11RHI\Private\D3D11Query.cpp:134

From this line above, I understand you should check this video:

This is nothing to do with Engine or Project. This is caused by Windows Regedit directly.

I simply Googled “DXGI_ERROR_DEVICE_REMOVED” string and saw that video.

Sorry for the delay, I need to explain that the D drive actualy belongs to the same HDD, its virtual separated and not physicaly, but I’ve tried it anyways, got the same result, it crashed again.

After that I’ve tried diferent things:

  • Installed an older engine version (4.18.3) on an diferent drive (C), without success.
  • Installed many driver versions, same result.
  • Disabled the PhyX on the NVidia controll panel, same result.

I’ve forgot to mention that this issue occurs with any project, even before creating a new project, It shows the usual loading screen, and then the project selection window appears black and then shows the crash window.

I think I will stick to the intregated graphics for now, if I discover a fix to the problema I’ll post it here.

Also here’s another log file from the crash related to the 4.18.3. link text

I did every step in the video in the link you provided and it works, the engine doesn’t crash anymore and works as expected.

Thank you all for your help and your time. The issue is now fixed.

Glad to see I could help someone.
I hope you will success at what ur doing.