Unreal Engine crash on loading specific map

Hello Everyone,

Since this morning I am having severe issues with launching my map in Unreal Engine. I have been working on this project without much problems in version 4.7.5 for a while now, even did so yesterday evening. For some reason since this morning I cannot get my map to load anymore and get this error when trying to do so, specifically mentioning an UncompressMemory error of which I don’t know how to fix it:

The project opens up fine when resetting the main-map to load (so it doesn’t crash entirely on startup), and I can run and open other projects and other test-levels within the same project. It is only when loading this specific level which crashes and gives this error when reaching 96% of loading.

What I have already tried:

  • Verifying Unreal install
  • Removing and re-installing Unreal Engine 4.7.5
  • Updating of graphics drivers
  • Downscaling of all texture maps to 128x128 resolution (I work with Substance and read somewhere on this forum that texture size could be a problem when given the UncompressMemory error.)

Unfortunately, these didn’t work as hoped.

What can I do to continue working on this map? I hope we can work this one out.


Also tried:

  • Clearing Cache of SwarmAgent and validating

  • Removing all Local AppData of Unreal

The project loaded much faster but unfortunately the level still crashes at 64%. I noticed that at the moment of the crash it is busy loading Lightmap_030. Any ideas?

Hi thompsongast -

In the level which is causing this crash for you, can you describe as much as you can about the navigation system you are using in the level? How big is your nav mesh volume bounds set as and how big are your nav chunks?

Let me know -

Eric Ketchum

Hello Eric, thanks for your reply!

I hope I understand your questions right, if not please let me know! I am learning interior design rendering as part of my graduation, this is my first project in the UE4.

I used the First Person Shooter BluePrint template when I started the project back in 4.3.4 and created a new empty map. I am using this to walk around in the level along with an animated fly-through camera which can be triggered at play (small edit in the level blue-print). The gun visuals and shooting system was removed as I only needed to be able to walk around in the area without the shooting mechanics.

Along the way of all updates and hotfixes up to 4.7.5 I have never experienced problems updating the project, also have been working in 4.7.5 for a while now.

Are these the nav mesh volume bounds you are referring to? -

If that is the case, I have not placed those in the level or if they are automatically there I haven’t change them knowingly.

If I can provide any additional information I’d be happy to help. I will now try and see if this problem also occurs on my laptop. If this is the case, would it be an option to send you the project? I will post my findings here in a new comment.

Hope to have informed you sufficient for now and looking forward to hearing back from you!

Best Regards,

Thomas Lazarom

Excuse me, all 4.7.5 engine versions I mentioned are supposed to be 4.7.6! Somehow overlooked it, my apologies!

Hi -

Hmm… I had traced your callstack from above to an issue involving Nav Mesh Bounds. Is there anyway you could upload a copy of the map file for me to try to dig into? If you want to keep it private you can link it from a dropbox or google drive to me via private message on the UE Forums.

Thank You

Eric Ketchum

Hi Thomas -

So I spent sometime trying to discover the root cause of the crash you are experiencing and believe I’ve narrowed it down to an issue with the Landscape in your Map file. The good news is I’ve input a report for this issue and we will be investigating a solution to this issue. The bed news is I cannot actively get into your umap file. Now if you look in your version of the project folder you should have a Saved Folder and you can recovery an older version of the umap file from the Saved\Backup folder and just copy it over top of the umap file that is crashing. This should allow you to get back into your level, however you will be missing some of the most recent work. The only over option currently is to build from scratch.

I will keep you informed as we continue to investigate a solution, but if you happen to recover a umap file that is not corrupted I would love to continue investigating with your project.

Thank You for you Help and from what I could get access to very excellent work with the project, we would love to see a finished version -

Eric Ketchum

I am having the same issue after installing brushify and adding landscape chucks to one of the demo map. its caused me to loose the map to to the engine not responding and on top of that its becoming an issue on many other maps. as soon as they cause the engine to not respond, just trying to load the same map after restarting my computer it immediately doesnt respond again. its so screwy that task manager cant even close the program in this state of being non responsive, i have to either log out or re start my pc. ****