Unreal Engine 5 - Project Won't Build After Switching between Rider and Visual Studio


I recently have been working with Unreal Engine and C++. I was previously using a mix of Visual Studio and Rider (Visual Studio for building, Rider for editing since it was faster).

Upon release of Rider 2022.1, I tried to use RiderLink to build my Unreal Engine project from source. I shut down ALL instances of Unreal Engine that I had running (I had a few open since I was moving code from Blueprints to C++). However, upon doing so, I was met with this interesting error that I have yet to figure out how to fix:

Visual Studio Log

Build started…
1>------ Build started: Project: FrameworkProject, Configuration: DebugGame_Editor x64 ------
1>Using bundled DotNet SDK
1>Log file: C:\Users\willi\AppData\Local\UnrealBuildTool\Log.txt
1>Creating makefile for FrameworkProjectEditor (no existing makefile)
1>UnrealBuildTool : error : Expecting to find a type to be declared in a module rules named ‘RD’ in UE5Rules, Version=, Culture=neutral, PublicKeyToken=null. This type must derive from the ‘ModuleRules’ type defined by Unreal Build Tool.
1>C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.MakeFile.Targets(44,5): error MSB3073: The command “C:\Users\willi\Documents\UE_5.0\Engine\Build\BatchFiles\Build.bat FrameworkProjectEditor Win64 DebugGame -Project=“C:\Users\willi\OneDrive\Rapidfire\Conniption Framework for Unreal Engine\FrameworkProject\FrameworkProject.uproject” -WaitMutex -FromMsBuild” exited with code 6.
1>Done building project “FrameworkProject.vcxproj” – FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Unreal Engine itself seems to be fine but the project itself refuses to package up. The code itself is error free - I hadn’t edited it at all before I tried Rider 2022.1 and before then it compiled just fine - but I cannot figure out where to fix this.

If you need any more information don’t hesitate to ask, and thanks in advance.

Is the Rider Link plugin, inside your project’s “Plugins/Developer” folder?

Have you tried to delete the “Binaries” and “Intermediate” folders and generate the .sln file again? Also, reinstalling Rider Link plugin?

I installed all of that and tried, but it didn’t work even then, that’s why I deleted it.

I deleted the plugin and its folder.

Now, the Binaries and Intermediate folders, I’ve only done parts of the Intermediate folder but I will try that. I will update if it doesn’t work.

Update: It did not work. I deleted the Binaries and Intermediate in both the main project files AND the plugin I created for my C++ game framework, and it is still not building at all.

My thinking of an alternative is to just launch a brand new project, recreate the plugin, and copy-paste the basic code to the new project (since it’s C++ and I can access it all outside of the editor without anything breaking). If all else fails then I might just go ahead and do that but I’d love to get this resolved before I resort to that.

So, did you ever find the solution. I got the same problem right now, I switched from Rider to VS just to check VS’s debugger and now my project won’t build in both IDEs…


I was never able to sort this out. I had to reinstall the entire engine at the time. Only after that did it work.

As of today, it seems to work fine - I now daily drive Rider with a source build of Unreal Engine 5.3.2 with just the MSVC Build Tools (no IDE) installed.

If I had anything to help you I’d provide it, but I have nothing. The quirks of custom and slightly-less-than-excellently-documented build systems…