Unreal Engine 5 not showing up to install? This worked for me

Install UE5 not showing up in Library tab, started downloading City Sample Showcase, Install button appeared in Library when the download for the showcase was in full swing. Stopped the download, started downloading UE5. Problem solved.

I saw the keynote for Unreal Engine 5 the other day and I was blown away by it and thought to myself, “I have got to try this!” knowing full well that I have almost below zero in experience when it comes to creating content like this! Anyway I fired up the Launcher to download, clicked the install button which brought me to the library tab for Unreal Engine but lo and behold nothing showed up! My first reaction was that it must be some sort of bug since I recently had updated the launcher to the latest version, restarted the launcher… same result. Tried uninstalling it, restarted my computer, nothing… still an empty library with greyed out + icon.

When in doubt, google is your friend but I came up empty handed. Noticed though that other users were having the same problem so at least I wasn’t alone in my struggle.

Finally, for some reason, I decided to try and download the City Sample Showcase in the Marketplace, when the download had started I clicked on Library and now all of a sudden the download button for Unreal Engine 5 showed up.

Not sure why this happened to me but it seems that I’m not the only one who had this problem, perhaps it’s a regional thing? I’m located in Sweden. However this solved my problem so I thought I’d share it and hopefully it helps others with the same problem.

Time to unlock the creative part of my brain!

1 Like