Unreal Engine 5 crashes when adding objects


I have a fresh install of Unreal Engine 5 on Windows 10. Whenever I create/load a project, and then try to add any object to my level, the engine immediately crashes with the following error message:

Assertion failed: MacAddress.Num() == 6 [File:D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\LevelActor.cpp] [Line: 292]

It happens seemingly no matter how I introduce new objects to my level — whether it’s adding them from the menu, dragging & dropping, or copy & pasting something.

I’m completely new to UE, so excuse me if there’s something I’m missing. I have tried Googling the problem, but nothing helpful has come up.

I hope someone here can help me :pray:

So as it turns out, MacAddress is literally referring to your networks on your PC. 1. I had a ton of disconnected virtual network adapters piled up, so I disabled them all, and now I can place actors in my levels without it crashing.

Woah… what an unlikely solution to such an odd problem. But sure enough, disabling all my inactive network adapters fixed it! Thank you for sharing the solution with us :slight_smile:

重启电脑后解决了, 奇怪的问题