Unreal Engine 5, Android game Failed to open descriptor file

I am having issues trying to deploy my game through google play and whenever I launch the game it crashes on the splash screen and says failed to load the descriptor file.
When I press okay the game crashes and if I try to reload the game it just keeps doing the same thing.
I configured my settings the way it was shown in (Packaging Android Projects in Unreal Engine | Unreal Engine 5.0 Documentation).

The only crash report I have shows: Native crash at signal 11 (SIGSEGV), in split_config.arm64_v8a.apk!libUnreal…

I am currently using:
Unreal Engine 5.0.2,
Android Studio 4.0
Visual Studio 2019
Pixel 2 on android 11 & Pixel 5 on android 12

With:
SDK: Target 30, Minimum 23
NDK: 21.4.7075529
JDK: 1.8.0_241
This is my log from when Packaging the Game for Android ATSC

This is my log for when I Quick Launch onto my Pixel 2 (same result for Pixel 5)

This is the screen that loads, as soon as you click Ok the game crashes, relaunching results in the same image:

These are my packaging, android, and Android SDK settings.

I have tried using Android Studio 3.5.3, as well as Visual Studio Code 2021.

I have tried changing
SDK, Target (21-31) Minimum (9-23)
NDK, (21.1.6452462),(24.0.8215888)
JDK, (1.8.0_77),(1.8.0_112),(1.8.0_202),(18.0.1.1)
based on forum suggestions all with either the same results or without packaging at all.

Other Things I’ve tried:

I would really appreciate any suggestions or fixes anyone can think of, this is my first time posting a question so hopefully I have provided enough information to help.

Thank you to everyone in advance!

1 Like

The same problem occurred on the linux platform, Does anyone has any idea to solve?

Check the Engine/Binaries directory, if not exist, try to create it manually.

This problem has been reproduced in Linux platform.

I found the root course is the engine will search the root path in below code block

Thanks for the suggestion, still not working though.
The Binaries already existed but I tried deleting and repackaging and it generated the file again but still with no change in my end result.
Back to the drawing board.

I not familar Android platform, but when I package project in Linux, the uproject file seems not be packaged in the pak file.

Can you try add a uproject file to your final package?

Just wanted to weigh in quickly… I was having the same problem (among many others) after upgrading an AR project from 4.27 to 5.0. I SEEM to have resolved them by some combination of the following things:

  • Downgraded NDK to v21.1.6352462 (r21b) from v21.4.7075529 (r21e)
  • Set package mode to ‘Development’ instead of ‘Shipping’
  • Unchecked ‘Package game data inside .apk?’
  • Explicitly set SDK & NDK paths
  • Set SDK API Level to ‘matchndk’
  • Added ‘android.permission.WRITE_EXTERNAL_STORAGE’ and ‘android.permission.READ_EXTERNAL_STORAGE’ extra permissions

As a disclaimer, I have yet to do a full release cycle with this and I’m still dreading getting everything to work on Mac for iOS…but I am again able to run my app on my test Samsung Galaxy S9+.

Hope this helps somebody!

image
I’m not sure, I have little familiarity with Android and none with Linux, but the uProject seems to be in my package so I don’t know that that is would be my issue?

I tried with the settings you provided and am still getting my error, my issue may be something else I’ve done, I’m not sure.