Unreal Engine 5.1 - Project corrupted/broken

So, I don’t know how this happened, but earlier today I was working on a project in Unreal Engine 5.1, and everything was fine. When I booted up my Epic Games Launcher just now, all of my 5.1 projects were gone from the recent projects list. I booted up UE 5.1 and manually browsed to my projects to open the most recent one, but when I opened it, half of the assets (Static Meshes, Blueprints, etc.) were gone, the sky was all black despite the ExponentialHeightFog, SkyAtmosphere, SkyLight SM_SkySphere and VolumetricCloud components still being present, and my missing assets don’t show up in the Content Browser, either, despite being in that folder on my hard drive.

I made sure not to save the project, but I also don’t know how to fix it, and I wasn’t able to at least import my Static Meshes and Blueprints into another project.

Is there any way to actively load an older auto save or repair my project? I’ve put days and days of work into it, and I haven’t dared to open my other 5.1 projects yet.

This topic has been moved from International to Getting Started & Setup.

When posting, please review the categories to ensure your topic is posted in the most relevant space. Hopefully, this category change will help to give you an answer.

In the meantime, good luck and happy developing! :slight_smile:

Hey there @Manostion! Welcome to the community. This is a bit of a weird one! I’ve seen some project files be disassociated before, usually because some of the metadata files got left out of source control, but since it doesn’t seem like you’re using that we’ll try some things.

Try backing up your project by making a pure copy, then delete these folders in it and relaunch:


these will be regenerated (but also hold your cached data which is why we backed them up).

If that doesn’t work, launch the duplicate project, remove everything from the content folder, let it register it all as missing, then close, replace everything in the content folder and relaunch. This sounds a bit odd but it’s worked before for file re-association.

If that fails we might have to try some other things, hopefully avoiding having to drill down into manual content replacement, but that’s the literal worst case scenario.

Hi there!

Thanks for the very fast response. Sadly, the first solution didn’t do the trick for me. As for the second solution, do you mean delete everything from the “Content” folder, while the project is open? Also, do you mean within the Content Browser (seems unlikely) or from my File Explorer (my guess). If it’s the latter, do I skip everything that shows as “in use” or do I delete that once I close the project?

Also, when you say “let it register it all as missing”, does that include clicking “Import” or “Don’t Import” or do I just close without saving when the files are deleted?

Apologies, I meant to say to move everything in the content folder while the project isn’t active, then relaunch it, then move it in. After you do that, they should reappear. I’m a bit under the weather so I may have mixed up the wording a bit!

Two things to add to this thread. I’m on an M1 MBP using UE 5.1.1 and this problem occurs every single time I delete my Intermediate and Saved directories.

To fix it, I have to:

  1. With the editor closed, move the content directory to somewhere else on the filesystem, as described.
  2. Open the editor. Obviously the content directory is empty
  3. Outside of the editor, move the content back into the project content directory.
  4. Relaunch the editor.

Seems to work.

Unreal Engine is at the same time worst and the best engine. I mean project problems occur and they are very tiring but when everything works it’s awesome. I have worked on anim blueprint so hard to get it right and now it just does not work. It says “The anim blueprint could not be loaded because it is corrupt.”