Unreal engine 5.0.2 not launching on macOS

Unreal Engine isn’t launching it shows up in the dock for a second and immediately goes away
I tried uninstalling and reinstalling but it’s still not launching.

Mac is apple m1 and up to date on macOS montery
Unreal engine is 5.0.2

Please help.

Also, this is my first time using any forum so I don’t know if I’m doing this report right.

Hi! Did you have any problems during the installation? For example, did the installation stop at approximately 22%?

Oops deleted that post by accident, yes it worked without getting stuck.

I was hoping that someone would know the answer to the question, because I have exactly such a problem :frowning:

It’s just that I also have a Mac air m1

5.0.2 might be bugged on m1

I spent two days trying to find situations on the Internet like in my case. Unsuccessfully. Do you think you should just wait for the next version?

By the way, for the sake of experiment, I tried to install the previous version 4.27… and everything was well established and worked.

hmm definitely sounds like its a bug on m1

It appears to be bugged with 5.3 as well

Does anyone know the answer?

This is the most annoying bug ever I have been trying everything

I found the answer! You need administrative permissions to install it the reason its really fast is because its downloading some fake version.