Download

Unreal engine 4 is slow while trying to move pieces only (small building)

Searched a little and I played around with some stats already. Culling and LODs someone mentioned previously. I tried playing around with these in the “Quick Settings” tab. I also have changed “Engine Scalability Settings” & “Material Quality Level” to be as low as possible.

Now the problem is it’s nothing to do with the world itself. It’s only moving pieces that causes problems and this is just a single building world. If I try to move it “right or left” “up or down” it takes 5 seconds to actually
move it.

Any tips with this? Also does anyone know if this comes down to the speed of RAM or my HDD speed?

Card GTX760
Ram - 16 GB
i5-4670 - 3.4GHz CPU

Yep, I have this same problem with large brushes. It’s related to having the huge brushes in the level somehow, I think.

I find that restarting the editor helps, or just making the brushes into static meshes.

I’ve tried restarting and it doesn’t really change much. Should I not be building with brushes?

Is there anyway I can combine everything into one piece then start working from it there again?

Turn off “update bsp automatically”. Edit>EditorPreferences>Miscellaneous It’s a workaround, but you will have to build your geometry everytime when you move a object

https://answers.unrealengine.com/questions/30308/bsp-long-freezes.html

Along with @fighter5347’s suggestion, this is what I do:

Have the main map where you’re building your level out.

Have another map you use to build out your brushes.

On the building map, build out your brush pieces and stuff, then MAKE A COPY (important - you lose the brush if you don’t make a copy before this next part) then convert it to a StaticMesh (there’s a button in the Details pane with a brush selected).

Your performance will still degrade if you leave the brushes in your building map, but you can then just disable the live updating of brushes, or save those brushes out and delete them so you’re only working on one at a time.

Go back into your main map, place your static mesh and you’re good.

That way you keep all your brushes out of your main map and prevent them from messing up performance in the editor, but still have the brushes around in order to change them later and still be able to make a new StaticMesh.

Yes I had the same problem. I especially noticed performance problems when I started getting fancy like creating a tower out of BSP’s.

For me, once I was done working on a peace I would just convert it to static mesh. Or you can create the item in something like 3D max and import it.

Im having the exact same problem on a high end laptop. it breaks your work flow when your waiting five seconds everytime you move something as simple as a box brush. Could it be a bug?

I don’t think it’s a bug. I think it’s probably a heavier load for the brushes than it is for a mesh.

I’m guessing Brushes would be a level two where static meshes would be a level one (I don’t know the exact terms on this). I just figure this is the case as I’ve seen in the past with computers.

IM using a Landscape with 8k x 8k. Its impossible to work. I hope the hint of n00854180t works, because i have no idea how i will build a entire city with 10 seconds lag afther moving a piece. Note I have a i7 3770k 3.5GHz, 32 GB Ram 1800 MHz, and a GTX 660ti 3G Vram.

That’s about the same as mine. I’m learning to transfer everything to static meshes and to only build one part at a time in a solo world.

After I cleaned my world a little (had a fountain) it was working great again. Just now to learn the static meshes to hope I don’t lag at all.

Just keep in mind guys that you may run into issues with lighting on static meshes sometimes while using Lightmass.

Also for your huge city @reneberwanger, you’ll certainly need to build those in smaller chunks then convert to static meshes. You might also turn off the live-brush-updates as mentioned in the thread previously, but I find that usually working with smaller pieces on their own and converting over to statics is enough to keep the workflow good.

Does it also happen when you switch to Unlit Mode? Try grouping some unneeded items into a folder in your Scene Outliner and visibility icon to hide the entire group.

Also, for first performance check, change to Lightmap Density, notice my closest mesh that’s red color?:

85eb5e3aa5a4d3faddcdd32729907aa58d94dea5.jpeg

Convert **brush **to static mesh, and then convert the static mesh to a Blueprint, for some reason blueprints seem optimized for performance, and can often solve lighting issues.

Sometimes it works, sometimes it doesn’t and the color will stay red.

I got it working pretty well, but this is still nice to see thanks for the late reply.