Download

Unreal Engine 4 is available for Win10 UWP app dev now

Would I be correct in assuming that apps developed in this branch of UE4 could be run on an xBone in dev mode ? Albeit with limited resources.

In theory, yes.

From the looks of my Xbox Device Portal backend , I am able to deploy applications remotely to my device from my pc.
@DaveVoyles The only issue that I’m having now is getting the engine properly built to get all this tested. I usually never have an issue building the engine from source. I forked it through github, then ran the setup to install the dependencies (which finished successfully) and then I generated the project files. The build was going well until it encountered some sort of issue with the output below:

Have I missed a step ? Perhaps there’s a dependency missing or something obvious ?

  • Edit * I changed the install directory to F:\UnrealEngine (My usual) and did a full rebuild. Still no luck I’m afraid.

Android is not a free platform.

I do not know if centennial will work in this instance. I’d recommend submitting a question to the GitHub repo, because I’m equally curious.

There are two partitions on Xbox One. An Exclusive one, typically reserved for AAA engines so that they can make use of most of the system’s resources, and a second partition which is reserved for UWP apps.

In the past, I believe UE4 ran on the exclusive partition. Because you are running this as a UWP, it will likely run under the shared partition.

does any one know how to fix this when i try to build the project file i have it in my root of my e drive 1a2201ab4829c65b0d10ef4dce019b9925aec00f.png

Do you have Windows 10 SDK insalled?

Continued Issues

Update 3

Ok , so cooking content for windows has been sorted out. The only issues that I am having is packaging for UWP32 and UWP64.

Update 2

Pertaining to the issues below, I restarted my machine and did a full clean and rebuild of the engine. Everything built without a hitch ! Excellent !

Now a new issue arises… I still can’t cook content for windows or package for UWP from inside the editor as illustrated in the images below:

When cooking content for windows

804f30c26e08bd1a8e88b38697760278b9160aef.jpeg

When Packaging for UWP64
Package For UWP64.jpg

When Packaging for UWP32
Package For UWP32.jpg

From Visual Studio I can build everything for Win64 but UWP stuff constantly fails, presenting build outputs such as the one below:


Update 1
As the repository is private I cannot raise an issue on github , I did make a comment on the most recent commit in hopes that I would get some support. You’ll find my message below. It is a bit long winded but I wanted to present as clear of a picture of the state of my situation as possible. Here’s to hoping that someone sees it.


Hello @jsyarrow . This commit resolved the silk_common.lib issue that I was having while trying to compile. I am having other issues however, I would be most grateful for any support or direction you may be able to provide.

I have built the engine from the latest branch as uploaded, There are errors and warnings that occur and 1 project fails to build as per the paste-bins below:

Full Build Ouput:

Error List Only Output:

Despite the errors, I am able to run the editor and create a blank blueprint project. In this simple test project, I tried cooking for Windows but the build part of the process fails. This is while I have UWP and Windows set as supported platforms. When trying to package for UWP from the blueprint project I get a message saying that I can’t build DebugGame from the editor and that I should try building through the IDE. So I create a new C++ class and get my VS solution setup.

From the IDE I am able to regularly build the Win64 version of DebugGame and it runs. However, when I attempt to deploy a UWP32 or UWP64 version I get the following output:

Test Project Deploy Output:

I have previously followed the guide below to ensure that my IDE is setup to build UWP applications :

I have tested general UWP build functionality both as a regular application in Windows and as one running on my Xbox One in dev mode. In both instances, there were no issues.

I thought perhaps that my Windows10 SDK may be out of date so I updated it and re-generated the UE4 Project files. I then performed a full clean and rebuild to no avail. My user account has full admin rights and I am running VS using “Run as administrator”, I also have visual Studio 2015 Update 3 installed. When building other branches of UE4 from github source I do not encounter any such issues.

Am I perhaps missing an SDK or dependency or a step in the setup process ? Or is there a workflow that I am unaware of ?

Apologies for the long winded message. I am not able to raise an issue on a private repository and there doesn’t seem to be anywhere else I can get support. I would be most appreciative of any assistance you may be able to lend me.

Kind Regards
MrNexy

no if i need it where do i get it from

no if i need it where do i get it from

download windows 10 sdk

What about achievements & In-App Purchases support?

Great news! It would be nice to have an official support from Epic too. And it would be nice to have uwp open source too of course!

So ,has anyone managed to get this built and fully tested yet ?
It would be kind of a relief to know that I’m the only one having issues getting everything working.

i have got it built but i cant export uwp apps with out problems and i dont know how to add my xbox to unreal so i can test

So we’re pretty much in the same boat then. You won’t be able to package for the xbox through the editor unless you have the XSDK installed. Getting that is a matter of having a workable product and being an accepted part of the ID@XBOX program.
What might work and what I’d like to test out, is compiling and packaging for UWP32 or UWP64 and installing it on the XBOX via the dashboard while it’s in dev mode. The hope is that is should function as it would be a UWP application and you can test those on an XBO in dev mode.

As far as technical limitations are concerned, the engine should be able to run on the XBO in dev mode. If I can build my prototypes and run them on my GalaxyS5 at 60fps then I don’t see why it shouldn’t be possible. This of course depends on the amount of time and energy MS XBOX ATG is willing to put into developing and maintaining this branch.

I don’t know if you need the XSDK for this. Let me check with the team now.

Thank you kindly Dave , it is very much appreciated !

I am currently having issues packaging for UWP 32bit. I am getting the following error w/ MakePri:

“MakePri : error 0x80080204: Appx manifest not found or is invalid. Please ensure well-formed manifest file is present. Or specify an index name with /in switch.”

My log looks practically identical to the build output that MrNexy previously posted. Perhaps this issue will resolve itself with the visual assets being set up correctly.

I am also curious if you need the XSDK/XDK for packaging to Xbox, as I am not currently part of the ID@XBOX program, but I’d love to deploy stuff to Xbox.