Unreal Engine 4 is available for Win10 UWP app dev now

I tried to use a Test Certification which I quickly created via a UWP test project inside of visual studio but I could not load it into the UWP Settings in unreal engine 4. Only tell me that it ‘Could not override Certification file’.

you need to turn on dev mode on you phone to do so go here

I have dev mode enabled, but still not able to install the app, instead its giving me following message:

Of course I turn on dev mode. But I haven’t signed app. And I don’t know how I must sign it. I have same message as Sentinel when used Test Certification.

This might help here you can try and sidelode the app if it is unmanaged

Turns out the Signing Certificate property had the same chicken-and-egg bug as the images. If you pull commit 2d8bed9 you should be able to provide a certificate through the UI.

You can generate a pfx file suitable for use during development and testing using something like:

Some notes:

  • You only need a certificate if you want to install a packaged version of your app (i.e. wrapped up as a single appx file). That’s particularly useful for devices that are in the default ‘Sideload apps’ mode; it may be less relevant for devices in Developer Mode where you can use an unsigned version (provided you don’t package it).
  • It’s important that your certificate Subject name matches the Company Distinguished Name, otherwise signing will fail.
  • The current implementation doesn’t support password protected certificates.

That’s handy to know. I was getting this error when trying to install a packaged UWP onto my XBO from the device portal.
A question about creating the pfx. I made a batch file using the commands provided above. Makecert pops up with a password request and I click none, after that I see the .cer and .pvk files appear in my folder. Then pvk2pfx fires off but unsuccessfully as the pfx file isn’t created in the directory. There is no error message however, I’m using the (x86) versions of makecert.exe and pvk2pfx.exe from the ‘Windows Kits\10\Bin’ folder structure.

Good catch, I was missing the -pvk switch . Here’s the fixed version (plus I’ve edited the original for the sake of those who come after)

Has anyone sucessfully gotten something to deploy on an xbox on in dev mode yet? Dont wanna put mine back into devmode until I know there is a proven work flow for gettign it deployed.
Hoping Unreal will perform better than unity did. it freaking crawled at like 5 FPS with a simple menu when I deployed from unity 5.

That helped in making progress , thank you !
I’ve got a new issue that’s preventing packaging of UWP64 and UWP32 using the resulting cert. I modified the supplied command to the following:

Once generated, I proceed to set the result as the certificate on the UWP page. I made sure to cook for windows and that finished successfully.
Below is the output from the editor when I try to package for UWP64. In the log it says to see ‘signtool-2016.08.05-13.08.24.txt’ for more details, after a thorough search of my system no such file exists.
I’m currently packaging for UWP32 to see if I get the same result.

[MENTION=3956]James Barnette[/MENTION]
I did manage to get my test game to install through the device portal by uploading the UWP contents from the build folder. The splash screen started up but because there was no cooked content it crashed. Once I have the cert issue resolved I’ll try it with a signed package or copy cooked content to my build folder and try that way again, though I think that signing the package may do the trick.

hey jsyarrow, thanks for the info for creating the certification, but I’m receiving following error during the package command stage:

I created two certifications, one with a password and one without just to see if I receive the same results. Any ideas what it could be?

Edit: Here is what the ‘signtool-2016.09.05-11.45.57.txt’ says:

Thank you for your help.
Now I have work package for PC.
But I cannot install this package on my Lumia 950 phone. Because I have next error:

As I understand architecture must be ARM but I have only x86-32 and x64 bit. (I checked their and I have same error in x86 and x64).
Would you like add windows phone as supported device? Or if windows phone already supported what I must do to launch app in my Lumia 950?

@MrNexy Awesome I am following with great anticipation! keep up the great work!

@MrNexy @Sentinel

I think you’re both hitting the same problem - we needed some quotes around the appx path to signtool. Try again with commit 9470688.

Yes, a build for Lumia 950 would require ARM which is not currently available. We don’t have anything to announce concerning future plans for this fork, but please do keep providing feedback on what you might be interested in. And if you decide to add ARM support yourself do let us know how it goes.

@jsyarrow , [MENTION=3956]James Barnette[/MENTION]

That sorted out the signing side of things. Everything now cooks,builds,packages and deploys without a hitch for UWP32 and UWP64 for the pc.
Now that the packages are signed I am able to successfully install them on my XBO through the device portal.



When I start up the application through the device portal the splash screen loads up on my TV and hangs there for a while. I’m then kicked back to the dashboard on the XBO and receive the following message in the device portal.


I don’t get any debug information(that I know where to find at any rate). After reading through the known issues for UWP on XBO and the resources allocated to UWP on XBO, I’ve come to the conclusion that the app is likely exceeding the available resources and throwing a memory allocation failure and closing. I get the feeling that this is as far as I’m going to get in terms of testing on the XBO, I could be wrong of course and would be very happy to be proven so. What I imagine is that the engine would have to be optimized to run on such limited resources, likely in much the same way as it has been to run on android. That said I am probably going to try and package a scalable prototype that I’ve been working on (and have packaged and run on android) for further testing.

What you are getting is a memory message because Xbox only lets you use half the ram In dev mode you need a dev kit to use the full features it has

Yup , from the specs it looks like UWP apps are limited to 1GB of memory on XBO. This is likely why basic unity apps run like tar. Let alone trying to run UE4. Looks like I’m going to be fleshing out one of my prototypes and re-applying to ID@XBOX :slight_smile:

Ya same I am going to apply again when I have a working muiltyplayer prototype

Wow exciting progress, guys!

I just got back from vacation. Excited to hop back in the UWP UE4 development boat. :smiley:

Update: S U C C E S S !
I’ve successfully built an app in UE4, packaged for UWPx86, and deployed it to a Microsoft HoloLens! YAY! However, I’m noticing some issues already.

When packaging for UWP, the Quit Game node does not function correctly. It does not exit/quit the game. I also tried an Execute Command node with the command “EXIT” executed. Also nothing. Both of these methods for exiting the application work just fine in the editor, but not in the resulting appx from the UWP packaging. I am packaging for UWP x86 - 32 bit. What is going on here?

My next challenge to tackle is to make the app into a 3D holographic app instead of a 2D app. If anybody has any great ideas on how I might do that, please let me know.

Hi. Does this fork have Holograpic APIs integrated?