Unreal engine 4 installer doesn't work - DLL required

I just subscribed the $19/mo plan and downloaded the installer.
But when I start the installation.
It says there is a problem with this windows installer package.
A DLL required for this install to complete could not be run. Contact your personnel or package vendor.
And the installation stops.
Any help on this?

Hello,

Thank you for your report. Could you please run the installer with the following command and then post the UnrealEngineInstallerLog.txt that is created:

msiexec /i UnrealEngineInstaller.msi /L*V UnrealEngineInstallerLog.txt

That will allow us to further investigate the issue.

Thanks!

Alexander

What is the size of the UnrealEngineInstaller.msi file that you downloaded? It is possible that it was not a complete download. If you right click on the file and choose properties, you should see that it is 51.3 MB (53,821,440 bytes).

Installer works now. I start the cmd.exe in administration permission. And launch the installer in cmd. Then it works. Probably it’s some permission issues.

I downloaded the 51.3MB one.

here is mine

=== Verbose logging started: 3/20/2014 0:22:18 Build type: SHIP UNICODE 4.05.6002.00 Calling process: C:\Windows\system32\msiexec.exe ===
MSI (c) (B4:D4) [00:22:18:449]: Resetting cached policy values
MSI (c) (B4:D4) [00:22:18:449]: Machine policy value ‘Debug’ is 0
MSI (c) (B4:D4) [00:22:18:449]: ******* RunEngine:
******* Product: UnrealEngineInstaller.msi
******* Action:
******* CommandLine: **********
MSI (c) (B4:D4) [00:22:18:458]: Machine policy value ‘DisableUserInstalls’ is 0
MSI (c) (B4:D4) [00:22:18:464]: Note: 1: 1402 2: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 3: 2
MSI (c) (B4:D4) [00:22:18:564]: SOFTWARE RESTRICTION POLICY: Verifying package → ‘c:\Users\hamyshank\Documents\UnrealEngineInstaller.msi’ against software restriction policy
MSI (c) (B4:D4) [00:22:18:564]: SOFTWARE RESTRICTION POLICY: c:\Users\hamyshank\Documents\UnrealEngineInstaller.msi has a digital signature
MSI (c) (B4:D4) [00:22:18:899]: SOFTWARE RESTRICTION POLICY: c:\Users\hamyshank\Documents\UnrealEngineInstaller.msi is permitted to run at the ‘unrestricted’ authorization level.
MSI (c) (B4:D4) [00:22:18:903]: Cloaking enabled.
MSI (c) (B4:D4) [00:22:18:903]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (B4:D4) [00:22:18:910]: End dialog not enabled
MSI (c) (B4:D4) [00:22:18:910]: Original package ==> c:\Users\hamyshank\Documents\UnrealEngineInstaller.msi
MSI (c) (B4:D4) [00:22:18:910]: Package we’re running from ==> c:\Users\HAMYSH~1\AppData\Local\Temp\2499925.msi
MSI (c) (B4:D4) [00:22:18:913]: APPCOMPAT: looking for appcompat database entry with ProductCode ‘{ADB715E9-AEE5-48EA-BCA9-63F4A764A80F}’.
MSI (c) (B4:D4) [00:22:18:914]: APPCOMPAT: no matching ProductCode found in database.
MSI (c) (B4:D4) [00:22:18:918]: MSCOREE not loaded loading copy from system32
This installation package is not supported by this processor type. Contact your product vendor.
c:\Users\hamyshank\Documents\UnrealEngineInstaller.msi
MSI (c) (B4:D4) [00:22:18:921]: Note: 1: 1708
MSI (c) (B4:D4) [00:22:18:921]: Product: Unreal Engine – Installation failed.

MSI (c) (B4:D4) [00:22:18:922]: Windows Installer installed the product. Product Name: Unreal Engine. Product Version: 0.1.0.0. Product Language: 1033. Installation success or error status: 1633.

MSI (c) (B4:D4) [00:22:18:927]: MainEngineThread is returning 1633
=== Verbose logging stopped: 3/20/2014 0:22:18 ===

My errorlog:
link text

getting the same issue, here is my log thingy also.

link text

Hi Makarei, can you post your dxdiag file? Are you using a 32bit OS or cpu?

I’m using a 32bit windows 7.

link text

Hi Makarei, unfortunately the installing the Unreal Engine requires a 64bit OS and CPU. Apologies for the inconvenience.

ok i will cancel my subscription and go back to unity. hopefully i can make a game to buy a better computer

It seems like you are running into a similar issue to the one reported in this thread: Link

Can you try grabbing an installer from the site Carlos posted in his answer to that thread?

I am also having the same Issue I have a 64 bit operating system, just bought UE4 and just tried to open the MSI and just gets the same error. Also followed these steps to get a log, but it couldn’t find it even when I put it on my C drive and changed the name to suit this example etc.

Thanks for the info. Is that the only language set on that machine? It would be useful to see some logs. Can you try to do the following…

• Place the msi on the root of C drive

• WindowsKey+R and enter:-

• msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt

• Replacing “UnrealEngineInstaller.msi” with the actual msi filename
And then upload the UnrealEngineInstallerLog.txt

No idea why it could be doing this, thanks.

Fixed with another thread, this may be helpful for others too.

This issue is probably being caused by the fact that your user and/or group lack some required permissions on the temp folder the installer extracts to. This folder can usually be found here: c:\Users{YOUR_USER_NAME}\AppData\Local\Temp

In your case, I would guess you have permission settings that are preventing the installer from executing from that folder. Can you check to see if your user has ‘Full Control’ of the folder below? If you don’t mind sharing, it would be really helpful for us to know what your security settings are for this folder before you make any changes.

C:\Users\Bear\AppData\Local\Temp
If you find none of your groups/users have Full Control you could try a few things:

First, as Leigh mentioned, you can run the installer from a command prompt that has been elevated. The one bit of info that is missing from Leigh’s description of the fix is that you need to select Run as Administrator when starting the command prompt.

An alternative fix is to just modify the folder permission settings so your user/group has Full Control. I hope you try this and report back because we have had a hard time tracking down the root cause of this issue. You can do this by right clicking the folder and selecting properties. The Security tab should show you who has access to the folder and what they can do with the contents. For example, if I wanted to fix something like this locally I could give the ‘Users’ group Full Control of the temp folder on my machine.

Halfway down this page are super simple instructions to add “Run MSI as administrator from Command Prompt”.

http://www.intowindows.com/how-to-run-msi-file-as-administrator-from-command-prompt-in-windows/

This is by far the easiest workaround.

I know this is kind of old but for anyone wondering how to install from the command prompt just cd to the directory that has the file then copy and paste the name of the file including .msi in the prompt.

Also thanks for the suggestion! Worked great for me.

This worked for me. Thank you. I’m always having trouble with my local data folder, it gets reset for no reason at all. Single user of the computer too.