Unreal engine 4 download

I restored my computer for personal reason but when i tried to install unreal engine 4 again i can’t seem to download the actual engine or anything from the marketplace. When i try to download the engine it just says that the download is in queue, i tried waiting but a few hours afterwards there was still no change. I’m not sure if maybe i missed a step in downloading the engine or what exactly is happening, maybe there is a software that i need to download for the engine that i do not know about (if so pleas help).

Hey Liam_St-Onge-

Are you downloading the launcher from the website or are you using the launcher to download an engine version?

I am using the launcher to download the actual engine.

Hi Liam,

Please try the troubleshooting steps linked below. Afterwards if the issue is still present, follow the steps at the bottom of the page to find your ‘Verbose Logs’ and post them here. They will help us track down the issue.



Sorry, for the trouble but I fixed it… I don’t think it had anything to do with the launcher or anything with the engine, there was something wrong going on with my computer and once i fixed it i could successfully download the engine. Thanks
for the help everyone and sorry for wasting your time.