Unreal Engine 4.8 'Please Wait...'

Windows 10
Trying to download UE4.8, stuck at ‘Please Wait…’ for an eternity.
I have attached the debug logs etclink text

Hi Sean,

I’ll answer this since I have the same problem. They are experiencing quite a few ‘please wait’ messages at the moment and they are looking into it.

I don’t believe the problem is client side, I’ve done some thorough checking.



Hi SeanGorman,

Cailban-AU is correct, we are experiencing a large amount of ‘Please Wait’ errors. We are currently investigating the issue.

Are you seeing the error on log-in or when downloading an engine version?

Please can you add the following as an exception to your firewall and see if that fixes the issue, thanks

xmpp-service-prod.ol.epicgames.com port 5222


I have disabled all firewalls completely and tested with the same result.
I don’t think its a firewall issue.

I have the same issue. I disabled all firewalls and have a direct connection.
I even disabled Kaspersky completely for a test. But I still get the “Please Wait…”

I am using Windows 10. Maybe this is an issue?

In the library tab, can you click “Add Version” multiple times and do you have 4.8.3, 4.9 preview in there?

Because on my first installation of the launcher both things mentioned were different ( could only add 1 version, and the selection was different ).
Afterwards I deinstalled the launcher, downloded it a 2nd time and installed it again.
This time I could instantly dowload the Engine.

He Sean,

Are you able to install other versions of the engine or the preview?

Following Induras1’s instructions solved this issue.

Hi everyone,

Give the workaround posted here a try. Let us know how it goes.