Unreal Engine 4.7.2 not downloading or installing

So here’s what I have:

I have the Epic Games Launcher downloaded and installed.

I disable my Firewall.
I run Epic Games Launcher as Administrator to be on the safe side.

The software opens and I receive a notice in the upper left corner of “Not Installed Unreal Engine 4.7.2.”

When I click the drop arrow, it shows “Unreal Engine 4.7.2,” and I appear to be able to click on it, but it does nothing else. I may have misunderstood, but according to (Installing Unreal Engine | Unreal Engine 5.2 Documentation), it should download automatically and start installing. This does not occur.

It does no behave as if anything is downloading or installing.

HI EvilNick,

To download an engine version please follow the steps in this forum post.

Thank you for pointing out the flaw in the documentation. I will enter a report to get that fixed.



Ah thanks! Geez, I guess I should have played around in the menus a little more, but library didn’t strike me as an obvious place to go.

It’s understandable. We are actually working now to simplify the install process the first time that the Launcher is install. Hopefully that will be coming out soon.

idk that forum post lends me to a place that says that is private or doesn’t exists, I already posted about the same problem and I can’t solve it

it still doesn’t let me install it, this appears, its in spanish btw. The forum of unreal engine its only a page that says that the page is private or doesn’t exists.

Yeah, the Unreal Engine Forums just underwent a big change, and there are a bunch of errors with old posts, which is why it says “That page doesn’t exist or is private”.