Unreal Engine 4.27.2 Could not initialize class org.codehaus.groovy.reflection.ReflectionCache


This similar error was resolved on a previous topic, but the Engine version was an older one.
I’ve been stuck on it the last 2 days.

this is the error :

Could not initialize class org.codehaus.groovy.reflection.ReflectionCache

show me please error log

Solution is still same… install JDK v8 (its already on oracle archive downloads site) Url Java Archive Downloads - Java SE 8

1 Like

Still doesn’t work for me unfortunatley!

You are so kind <3 … Helped me much … now it works

You need to update the jdk path in your project settings

Hey @Leboulier23, I don’t know if anyone welcomed you to the forums yet, but welcome!

Did @999999333’s solution work for you?

I had success with Corretto 8 (no login required, unlike the Oracle JDK):


From: Releases · corretto/corretto-8 · GitHub

I opted to install it in D:/ue4/AmazonCorretto8, unselected the option for modifying JAVA_HOME and PATH environment variables (to reduce potential breakage/conflicts later), and set in my UE4 project settings → Android SDK → Location of JAVA: D:/ue4/AmazonCorretto8/jdk1.8.0_362

1 Like