Unreal Engine 4.26 keeps crashing after every interaction

I find it that using Unreal Engine 4.26 has become totally unusable.
I created the project using Architecture template and another one is just the sample project from the UE4 Lighting Course.
It keeps crashing for every button press or some node edits.

And the log either says D3D Device lost or attempt EXCEPTION_ACCESS_VIOLATION reading address 0x0000000000000018

I am running on a pretty decent rig with
Ryzen 5 2600
RTX 2060 with latest drivers (studio and gaming)

I tried setting the TDR value to 10 following some other forum. It helped to an extent.
But now I turned on GPU Lightmass and it crashes every second practically making it unusable.

I have raised a ticket but no response yet. Which is understandable as its Christmas and New Years eve.

Any help or guidance is greatly appreciated.

Karthik Hebbar

That’s the exact same problem I’m facing after every interaction. Also after using it for at least 10 to 12 minutes max. Any solutions ?

what is your processor/gpu?

i can confirm ive been having this exact same issue ever since 4.26.0 came out, and it happens on multiple projects, itll happen when i have a blueprint open, make a new variable, and try to plug it into something in the graph

@20heUnk14own I’m happy to see that I’m not the only one. They shouldn’t have released 4.26 out of preview itself. Very Unstable. Like Cyberpunk 2077.
@ugmoe mines Ryzen 5 2600 and Rtx 2060

Exactly, even when I try to just add an object it lags for sometime. Sometimes it freezes and after 2 min the screen blinks after every cursor movement. I don’t really know what’s the problem

And not only this version, also 4.25 crashes a lot and after using it for approximately 10 to 12 minutes it freezes sometimes I’ll have to force shutdown the pc

Can we upvote the question or link it somewhere ?. So that we can get attention of more people and inturn the project manager or lead support staff can get noticed so as to get a hot fix releases for both versions quickly

On Linux 4.26 keeps on crashing for me too. It does every time when I drag any new object to my level. If I duplicate an existing object, compile, build, use material or blueprint editor, it works without issues. I will revert to 4.25 for now, on that version all worked well. I am on a i7-9750H, 1650 Max-Q.

same here, tried older versions too every version i tried same result. unusable to do anything other than navigate in viewport. completely freezes the computer. tried bunch of things from other threads but nothing works. did anyone find a solution ?

Did a fresh install of windows 10, thats the only thing that worked for me after trying many many other things.

Yes, me too. When I add a new public UPROPERTY to a C++ file that has a blueprint inheriting from it. Mostly if that blueprint itself is open, but sometimes even if it’s not open. I get that same crash message as original post. Hoping it’s fixed now in 4.26.1.

Edit: It’s worse in 4.26.1, now after I change or add something to a public UPROPERTY all blueprints that I use the cast to “that class” with seemingly requires I replace that node with a new node of the same type. The other solution is to delete the binaries and rebuild the project every time you do this.

I just installed and it’s barely usable. I have to save every 2 minutes to prevent losing my project.

Freshly reinstalling windows was the only thing that worked for me. Was a pain in the a**, but for me at least it meant the problem wasn’t ue4 but something on windows side.

On Linux at least, 4.26.1 runs smoothly now

We’re having the same issue. Version 4.26.1 is crashing regularly on Windows 10. It would be good if there was solution mentioned that doesn’t involve reinstalling windows. It’s unusable right now.

Try updating your drivers.

This page describes a number of ways to stop the “D3D” crash – I found it solved this problem on my system: https://appuals.com/how-to-fix-the-error-unreal-engine-is-exiting-due-to-d3d-device-being-lost/

For me, turning off overclocking of my GPU & Memory did the trick – note that I had a very mild overclocking setting that never crashed in any other program (not even intense VR rendering with high GPU utilization) – the only thing that crashed was the Unreal Editor itself, and it did that every few edits, just like in the original question.

Having the same issue… Reinstalled nvidia studio drivers and tried multiple engine versions. New project will flicker black, freeze, and crash when trying to do anything important. Then get a GPU D3D device being lost error. Do not have any issues with blender or any other program or game… Last time I used unreal back in 4.20 I did not have these issues. Same computer and hardware. The engine is currently unusable in this state. Last thing to try is to reinstall Windows 10.

FYI when I was receiving “D3D device lost” on my machine (and it wasnt just Unreal, it was lots of games using Direct3D) it was because my PC has a Skylake CPU and I needed BIOS updates to apply the fixes for the AVX instructions Intel released some time after the chip came out. I didn’t have the problem for quite awhile after getting the CPU presumably because apps weren’t using AVX as much as they do now. You might want to look at your CPU model and any errata that has been released for it and apply any necessary BIOS updates.