Unreal Engine 4.24 Released!

Tried both versions of the source and errors occurred. Does Chaos work with 4.24?

yyyyyyyyyeeeesss!

Are you picking the source from this page? https://github.com/EpicGames/UnrealEngine/releases I didn’t try yet, but just to make sure you got the correct source.

No from github. I will try it next. Have been able to get the compile to work?

I am still waiting for a set of jobs to be completed on the machine I use to compile and I will try that next.

Just tried https://github.com/EpicGames/UnrealEngine/releases . More errors. NilsonLima If you get to work, please be very explicit on how if it works. Are going to do it today? Thanks.

Same here! The new example looks great. Hope to be able to access it soon.

I am unable to generate project files with UE4.24 (installed from the Launcher). I have no problem with 4.23 or previous versions. The error is:


ERROR: Could not find NetFxSDK install dir; this will prevent SwarmInterface from installing.  Install a version of .NET Framework SDK at 4.6.0 or higher.

I’ve never installed any .NET Framework directly, only installed Visual Studio and everything was smooth. What it can be?

// NOTE. The Polygon Editing plugin is only supported on 64-bit Windows.

Some render features such as SSGI, Raytracing, RTGI and etc. does not supported yet on macos (RX, VEGA hardware).
:frowning:

Is the non-volumetric cloud material that Ryan Brucks showed off in the last livestream available somewhere?

Not talking about the volumetric material that he said was on GitHub, I mean the unlit material he described as faking lighting with a “bump-offset type shadow”…

Timestamped (1:06:06) Link

Is there some information about how to set up Sparse Class Data somewhere?

Does anybody know why bSingleLayoutPass in the Performance category was removed from the widget ScaleBox in 4.24? I need it so my frame rate will go above 15fps.

So SSGI does not work with Forward rendering correct?

Horror of horrors… Can’t undo changes in material instances. The message appears but the values don’t go back.

I’m also having no success trying to do a Chaos build of 4.24.0. I’ve downloaded the 4.24.0-release branch via Git, and added


bCompileChaos = true;

to Engine/Source/*.Target.cs, but I’m getting the failure below. I’m trying to make an installed build using:


Engine\Build\BatchFiles\RunUAT.bat BuildGraph -target="Make Installed Build Win64" -script=Engine/Build/InstalledEngineBuild.xml -clean -set:WithWin64=true -set:WithLinux=true -set:WithServer=true -set:HostPlatformDDCOnly=false -set:WithWin32=false -set:WithMac=false -set:WithAndroid=false -set:WithIOS=false -set:WithTVOS=false -set:WithLinuxAArch64=false -set:WithPS4=false -set:WithXboxOne=false -set:WithSwitch=false -set:WithLumin=false -set:WithLuminMac=false -set:WithHoloLens=false

It looks like it’s trying to mix Chaos and PhysX types, so I thought perhaps Chaos isn’t fully integrated in this release and not meant to work, but then there are references to some new Chaos features in the 4.24 release notes.


  ** For UE4Editor-Win64-DebugGame + UE4Editor-Win64-Development
  Module.GeometryCollectionEngine.cpp
  C:/UE/UnrealEngine/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1948): error C2440: 'initializing': cannot convert from 'FPhysScene *' to 'Chaos::FPhysScene_ChaosInterface *'
  C:/UE/UnrealEngine/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1948): note: Types pointed to are unrelated; conversion requires reinterpret_cast, C-style cast or function-style cast
  C:/UE/UnrealEngine/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1949): error C2027: use of undefined type 'Chaos::FPhysScene_ChaosInterface'
  c:\ue\unrealengine\engine\source\runtime\experimental\chaossolvers\public\PBDRigidsSolver.h(64): note: see declaration of 'Chaos::FPhysScene_ChaosInterface'
  C:/UE/UnrealEngine/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1952): error C2039: 'GetScene': is not a member of 'FPhysScene_PhysX'
  C:\UE\UnrealEngine\Engine\Source\Runtime\Engine\Public\Physics/PhysicsInterfaceUtils.h(11): note: see declaration of 'FPhysScene_PhysX'
  Module.Engine.10_of_45.cpp
  C:\UE\UnrealEngine\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): error C2664: 'uint32 FindFaceIndex(const FHitLocation &,const FVector &)': cannot convert argument 1 from 'ChaosInterface::FSweepHit' to 'const FHitLocation &'
  C:\UE\UnrealEngine\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): note: Reason: cannot convert from 'ChaosInterface::FSweepHit' to 'const FHitLocation'
  C:\UE\UnrealEngine\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): note: No user-defined-conversion operator available that can perform this conversion, or the operator cannot be called
  C:\UE\UnrealEngine\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): error C2789: 'FaceIdx': an object of const-qualified type must be initialized
  C:\UE\UnrealEngine\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): note: see declaration of 'FaceIdx'
BUILD FAILED:  failed, retries not enabled:
AutomationTool exiting with ExitCode=1 (Error_Unknown)
BUILD FAILED

I can also confirm that I cannot build with Chaos enabled.

Can’t wait to test new features!

I built the engine from source without Chaos enabled.
I then compiled with bCompileChaos=true;
I have this error

1> [308/2734] Module.GeometryCollectionEngine.cpp 1>Z:/Unreal Engine Repository/4.24/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1948): error C2440: 'initializing': cannot convert from 'FPhysScene *' to 'Chaos::FPhysScene_ChaosInterface *' 1> Z:/Unreal Engine Repository/4.24/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1948): note: Types pointed to are unrelated; conversion requires reinterpret_cast, C-style cast or function-style cast 1>Z:/Unreal Engine Repository/4.24/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1949): error C2027: use of undefined type 'Chaos::FPhysScene_ChaosInterface' 1> z:\unreal engine repository\4.24\engine\source\runtime\experimental\chaossolvers\public\PBDRigidsSolver.h(64): note: see declaration of 'Chaos::FPhysScene_ChaosInterface' 1>Z:/Unreal Engine Repository/4.24/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1952): error C2039: 'GetScene': is not a member of 'FPhysScene_PhysX' 1> Z:\Unreal Engine Repository\4.24\Engine\Source\Runtime\Engine\Public\Physics/PhysicsInterfaceUtils.h(11): note: see declaration of 'FPhysScene_PhysX'

I cant find anyway to add a wind to GroomHair???

Answering partially to what i noticed: there’s a new behaviour for Nvidia GPU owners, while previous engine version were not impacted by nvidia control panel settings (i had vsync forced ‘on’, yet my editor framerate was at 120fps).

From 4.24 Nvidia control panel settings are effective in editor viewports, as well as PIE.

I’ll see if it fixes my Editor crashes, but it seems i was forcing triple buffering and vsync in editor.