Unreal Engine 4.24 Released!

Would be good for this version to note on the release notes, that there are multiple Paper2D optimizations and fixes.
Would be good to have that there, so people would know that this is the version they should be getting.

Did the engine space requirements change? When trying to install a launcher build it says 65.47GB is required which is double the size of 4.23.
Edit: after restarting the launcher and trying again it seems to work better.

Yes, they need to update too.

I tried and double checked if I got all setup right, even re-downloaded the demo with 4.24 selected . There are some errors and even still being able to run the Demo, the destruction is not happening and several code assertions are being triggered, looking at the comments where the assertions happened, there are still design attempts and not implemented functionality, so overall, wait for them to release an update regarding Chaos on 4.24 and still use 4.23 for the time being.

I have installed 4.24, created a new Architectural project, with raytracing enabled by default, and it simply crashes before opening. You too?

Build 4.24 with Chaos gives errors

Error C2789 ‘FaceIdx’: an object of const-qualified type must be initialized UE4 D:\UnrealEngine\GitBuild\4.24.0\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h 286

Error C2664 ‘uint32 FindFaceIndex(const FHitLocation &,const FVector &)’: cannot convert argument 1 from ‘ChaosInterface::FSweepHit’ to ‘const FHitLocation &’ UE4 D:\UnrealEngine\GitBuild\4.24.0\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h 286

Ok, so we can no longer create/edit VR input mappings in blueprints using Add Mapping node because VR keys are no longer accessable in BP due to new SteamVR Input method :. Will we get it back in future or is it gone for good?

In project from 4.20 reimport of static meshes (Datasmith ONLY!) failed every time in 4.24. Plugins section - all that have any connection to datasmith is enabled. But seems that everything that is already imported into the scene from 4.20 can’t be changed and should be imported and tweaked from scratch. Standart fbx. model are ok, reimport works fine. Any ideas how to fix it?

Worked fine for me with raytracing enabled, using NVidia drivers 441.41 from 11/26th/2019 and GTX1080, giving around 38+FPS realtime in play mode (showing a sequencer).

PS: there is a new driver release 441.66 which I didn’t installed yet.

Same there, can’t compile engine with Chaos enabled.


1>--------------------Project: Default-------------------------------------------
1>** For UE4Editor-Win64-Development **
1>Module.Engine.10_of_45.cpp (13:01.51 at +0:00)
1>E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): error C2664: 'uint32 FindFaceIndex(const FHitLocation &,const FVector &)': cannot convert argument 1 from 'ChaosInterface::FSweepHit' to 'const FHitLocation &'
1>E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): note: Reason: cannot convert from 'ChaosInterface::FSweepHit' to 'const FHitLocation'
1>E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): note: No user-defined-conversion operator available that can perform this conversion, or the operator cannot be called
1>E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Source\Runtime\PhysicsCore\Public\PhysicsInterfaceUtilsCore.h(170): note: see declaration of 'FindFaceIndex'
1>E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): error C2789: 'FaceIdx': an object of const-qualified type must be initialized
1>E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Source\Runtime\PhysicsSQ\Public\SQVerifier.h(286): note: see declaration of 'FaceIdx'
1>
1>Error executing E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Build\Windows\cl-filter\cl-filter.exe (tool returned code: 2)
1>Module.GeometryCollectionEngine.cpp (14:23.42 at +0:00)
1>E:/UE_4.23/UnrealEngine-4.24.0-release/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1948): error C2440: 'initializing': cannot convert from 'FPhysScene *' to 'Chaos::FPhysScene_ChaosInterface *'
1>E:/UE_4.23/UnrealEngine-4.24.0-release/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1948): note: Types pointed to are unrelated; conversion requires reinterpret_cast, C-style cast or function-style cast
1>E:/UE_4.23/UnrealEngine-4.24.0-release/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1949): error C2027: use of undefined type 'Chaos::FPhysScene_ChaosInterface'
1>E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Source\Runtime\Experimental\ChaosSolvers\Public\PBDRigidsSolver.h(64): note: see declaration of 'Chaos::FPhysScene_ChaosInterface'
1>E:/UE_4.23/UnrealEngine-4.24.0-release/Engine/Source/Runtime/Experimental/GeometryCollectionEngine/Private/GeometryCollection/GeometryCollectionComponent.cpp(1952): error C2039: 'GetScene': is not a member of 'FPhysScene_PhysX'
1>E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Source\Runtime\Engine\Public\Physics/PhysicsInterfaceUtils.h(11): note: see declaration of 'FPhysScene_PhysX'
1>
1>Error executing E:\UE_4.23\UnrealEngine-4.24.0-release\Engine\Build\Windows\cl-filter\cl-filter.exe (tool returned code: 2)
1>---------------------- Done ----------------------
1>
1>    Rebuild All: 0 succeeded, 1 failed, 0 skipped
1>
1>1 build system warning(s):
1>   - Temporary license has expired
1>
1>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Microsoft\VC\v160\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command "..\..\Build\BatchFiles\Build.bat -Target="UE4Editor Win64 Development" -Target="ShaderCompileWorker Win64 Development -Quiet" -WaitMutex -FromMsBuild" exited with code 5. Please verify that you have sufficient rights to run this command.
1>Done building project "UE4.vcxproj" -- FAILED.
========== Build: 0 succeeded, 1 failed, 2 up-to-date, 0 skipped ==========

Very nice set of features and improvements, thank you!

Is there a way to author the hair in Blender? It has some grooming tools, but if I’m not mistaken, no alembic export…?
Also, is it suitable for stylized hair strands, to simulate hair physics of simple mesh-based stylized hair like these?

Epic Chaos is working in 4.23. You release 4.24. Why doesn’t Chaos work in 4.24? Very strange.

So we noticed immediately after upgrading to 4.24 from 4.23.1 that the Paper2D Normal Buffer was acting as if it was Y-Up… Thus things like ambient occlusion and any other world normal based system was horrifically broken on paper2D Sprites and flipbooks. This seems to be from a recent optimization that utilizes a new vertex buffer. At the end of the buffer you can just simply change TangentZ to GetTangentY()
Engine/Plugins/2D/Paper2D/Source/Paper2D/Private/PaperSpriteVertexBuffer.cpp line 150
Old


TangentBufferData[2 * i + 1] = Vertices*.TangentZ;

Fix


TangentBufferData[2 * i + 1] = Vertices*.GetTangentY();

I am not a graphics programmer… so its possible this could be wrong in other ways, but at the moment this seems to have fixed the issue for us.

What’s up with the new hair? Any tutorial? I’m confused, since in documentation you’re claiming it should be available also for 3ds max somehow (with Ornatrix only I suppose), but first image clearly says xgen from Maya, and at this point it stops here… no more explanations whatsoever. Can’t find any info or tutorial on how it works, or what should I download/use, what or how to import/export…
I’m clueless, but completely interested!
Would be awesome if that could work without Ornatrix and with Blender as well… we (indie developers) don’t sh*t money for all these plugins you know, right, right?

Edit: Okay… I red right now how demanding that is, so I give up up that… 30fps with GTX 2080Ti… oh well, I will think about that in the next decade.

Same here, i’m very surprising that this problem is still in the final release

Has anyone even filed bug report about that? (I’ll upvote it if it’s a public one)

Guys does SSGI work with Forward rendering?

Found the same problem. Getting “none” returned when I’m trying to play footsteps audio based on the physical material in a landscape layer. Would like to know how to resolve this.

Anyone else notice this regression?

When hitting reset, it no longer goes back to the number it reset to in floatfields.

The errors regarding the Tangents come far back from 4.19, i personally coded the changes to add the new VertexBuffer and fixed them too, although the pull request was somewhat adapted to the engine, the tangent issue shouldn’t be happening anymore… or at least, it should be different from 4.19 which has the Tangents flipped.
This only happens though, if you use the new Vertex Path, there’s still the DynamicMeshBuilder path, which is incredibly slow, but is the 4.19 to 4.23 version.

Cheers