Unreal Engine 4.22 Constantly Crashing

I thought it was the DPI setting, too many blueprints, or some other reason but everytime I scroll to through that same right click options menu it crashes specifically when I hover over “skeletal meshes” Not to mention 4.21 and 4.19 crash as well. No its not my computer because I have an RTX 2080 MSI 32 gb laptop. This is an issue using the third person template as well when you right click the walls and sometimes when using the editor preferences. Fix this. I have 3 games to work on.

*scroll through, settings, crashes

Considering you have laptop, and most likely NVidia+Intel, you probably have common issue that everybody have, and sorry to inform you… it is most likely your laptop. Your laptop to conserve power switches to Intel GPU which crash UE4’s RHI. To stop it you need to set up your laptop power managment configuration to always you NVidia GPU, it also good to have keep plug laptop to AC to avoid it. You need to gogole info on how to do it for your laptop

But ofcorse it can be something else, to confirm this please provide logs from Saved/Logs in your project directory

I changed every power plan possible, restarted, selected ue4 editor in the nvidia panel, still crashes. Which one do I show you?

Change the compatibility setting to windows 7 (sometimes 8 works too) and disable full screen optimization

The one without date is the newest.

What windows do you have?

10 and its a brand new laptop. This happened on my old one too. It worked again yesterday but now with the same settings it doesnt.

I have no idea how to fix and I’m not up to searching through the code unless you know where to look. Where can I find the Event Driven Loader to disable it?

I’m having the same issue . The same crash logs as well. The project starts normally and then when i click any button like show fps it crashes instantly, no idea why this happens. Btw i have a msi g63 laptop

I have the same problem. It is strange that mainly laptop owners write about such problems. This is not the first year that the forums have written about this, and no decisions have been made up to now.

There is still yet to be a fix. This occurs in every version.

As odd as it seems its happening to mostly MSI laptops for some reason. I checked most of the other posts and they were all MSI laptops. maybe im wrong but it’s still weird. wish they fixed it.

not only on msi

I’m running on a Razer, but have the exact same issue