Unreal engine 4.18.1 crashes on launch

I recently upgraded to 4.18.1 and it will crash everytime on load. Here seems to be some key errors in the log file.

From the error below I think it is actually my onboard graphics card won’t support 4.18? Seems like a D3D error and my onboard graphics is old (video card died and waiting for holidays to get new one)

[2017.11.21-18.19.20:374][ 0]LogSlate: Took 0.000206 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Slate/Fonts/Roboto-Bold.ttf’ (160K)
[2017.11.21-18.19.22:507][ 2]LogD3D11RHI: Error: Direct3DDevice->CreateTexture2D(TextureDesc,SubResourceData,OutTexture2D) failed
at D:\Build++UE4+Release-4.18+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Texture.cpp:441
with error DXGI_ERROR_DEVICE_REMOVED,
Size=2048x2048x1 Format=(0x00000041), NumMips=1, Flags=D3D11_BIND_SHADER_RESOURCE
[2017.11.21-18.19.22:507][ 2]LogWindows: Windows GetLastError: The operation completed successfully. (0)

Below are other errors, but people have reported getting those and they are no big deal.

LogWindows: Failed to load ‘aqProf.dll’ (GetLastError=126)
LogWindows: File ‘aqProf.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi32e.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi32e.dll’ does not exist

4.17 still loads and run fine.
I have tried removing and reinstalling, verifying and still nothing.
I did somewhat recently lose my graphics card (died on my GTX 560), so I am running onboard intel 2000 graphics which is no fun, but did work for 4.17 enough. Those drivers are up to date.

I get the same failures in the log but my game doesn’t crash, I just don’t see anyone but the local player (I’m running a dedicated server setup and I get the log errors on the server side).

My logs always reads “Faulting application name: Tobii.EyeX.Engine.exe” … I know that Tobii Eye Tracker has a plug in for UE4. Could that be the source of the errors, or just a result of the crash?

I can get Unreal 4.18 to launch if I disconnect from the internet. After that I can connect to the internet while UE4.18 is running and experience no interruptions.

I updated it and found a different error at bottom of the file I missed before. It looks like a DX11 D3D issue so I am guessing my old onboard graphics are barfing at that.

I did try to disconnect from internet and still same issue, thanks for your suggestion anyway

This might not be UE4 related. Here’s Microsoft’s description of the DXGI error: The video card has been physically removed from the system, or a driver upgrade for the video card has occurred.

Try doing what’s in the answer found here: https://answers.ea.com/t5/Crysis-Games/DXGI-ERROR-DEVICE-REMOVED/td-p/1118490

GL,
Jin

Yay new hardware! Enjoy – and enjoy the time without UE4. Go smell some flowers or something, get outside. Wish I could. :slight_smile:

Thanks Jin,
This really seems to give much more credibility to the issue being my “video card / driver”. My onboard graphics is 6 ish years old so I don’t doubt this is the cause. I do have latest update drivers but those are from 2013. I just ordered a new card from newegg so hopefully in a week or so the new card will resolve my issues. I already tried all the steps but the dxwebsetup, with no luck. I am not actually expecting any success. Intel 2000 onboard chipset is probably pretty rare these days. Plus I can still use 4.17 for now anyway.

I did try and fix my snowblower for the winter, no luck with that. I am just getting into UE4 as I did mostly blueprint fiddling on and off. Now I am finally trying my hand with C++. It is funny how much pointer work I forget from not doing C++ for 10 years, or the simple things I take for granted from C#. Making progresses so that is fun. Good luck trying to find some flowers yourself

Hey, this person Sleeq says you can roll your drivers back to “16.12.2 Radeon” and that fixes the problem. You may be able to use UE4 before the new card arrives, if you want.

Open your CMD in admin and then type sfc /scannow and enjoy fortnite!