Unreal Engine 4.14.1 Display Driver Crash With New Project

Unreal Engine crashes the NVIDIA display driver. This crash happens when accessing
certain editor windows as outlined below. I understand that there are other similar
reports, and that Epic staff are having trouble reproducing the issue. On my
machine however, this error is happening on a brand new project with only default
template content. Hopefully that will make this easier to reproduce. For reference
the other related reports are:

System Information

  • Operating System: Windows 7 Home Premium, 64-bit (Service Pack 1)
  • DirectX version: 11.0
  • GPU processor: GeForce GT 555M
  • Driver version: 376.19
  • Direct3D API version: 11
  • Direct3D feature level: 11_0
  • Memory: 8192MB RAM
  • Available OS Memory: 8096MB RAM
  • Resolution: 1920 x 1080
  • User DPI Setting: 130 DPI (135 percent)
  • System DPI Setting: 120 DPI (125 percent)

Steps to Reproduce

  1. With the Unreal (Engine) Project Browser, create a new C++ project from the C++ tab.
  2. Set the following project settings:
    • Template as “Top Down”.
    • Target hardware as “Desktop/Console”.
    • Quality as “Maximum Quality”
    • Starter Content as “No Starter Content”
  3. Select the project name and location.
    (I used "C:\UnrealTest" and “TestTopDown”.)
  4. The project should be created with no issue. The editor
    and Visual Studio should both open.
  5. I don’t think this makes much of a difference, but I also waited
    for Visual Studio to finish parsing included files before I
    continued with these steps. While waiting the Unreal Editor
    remained open and stable.
  6. Using the content browser open “Content/Mannequin/Character/Mesh/SK_Mannequin”.
    An editor window should open showing the Mannequin.
    (I have experienced occasional, though inconsistent crashes just by
    opening this asset.)
  7. Maximize the new editor window to full screen.
  8. A tool-box on the left hand side should contain variables associated
    with the asset. Mouse over any of them such that a tool tip with the
    variable’s description is shown. At this point the display driver
    should crash and Windows should show a notification bubble that it
    has recovered.

Additional Notes

  1. On my end the crash is usually immediate. On occasion however, the driver
    will survive the first few tool tips. It will always crash with multiple
  2. In addition to the above I’ve also attached the stack at the time of
    the crash and the log output using the “-d3ddebug” switch on the editor.

A friend of mine was experiencing this same type of outcome.

He was able to work around the issue by using an older version of his video drivers.
His is the 560M so pretty close.

The driver he used is: 375.70

Hey edgesdarkly,

So this crash is related to one of our top crashes and we have been looking for repro steps, so thank you for providing such a detailed bug report.


Update: The 4.14.2 Hotfix release should resolve this crash as well as others similar or related. If you are still getting this crash after updating, please let us know and we will continue to track down the issue.

A good portion of these crashes are related to lower end machines using less RAM which is where the HUNG or REMOVED error message. We will continue to investigate this issue, and try to reproduce this crash internally to get a fix in place.

Let me know if you have additional questions.


Hi Andrew,

Thank you for providing a link to the issue listing for this bug. I also wanted
to add that reverting the driver to 375.70 as learningOver suggested does not
resolve the issue.

Fortunately, Unreal Engine v4.13.2 is stable using the 376.19 driver, so I’ll
continue using that version for now.

Same here my AMD Radeon Driver si crashing when it updated. But before the driver updated my unreal engine doesn’t crash.

Same issue here with 4.14 :frowning: My Engine keeps on crashing every single time I open. I also can’t downgrade my driver since Windows 10 has an issue wherein you can’t install your own driver and must be downloaded from the Windows Update process.

I also have this problem. My card is NVIDIA GeForce GTX 560 Ti. Didn’t have this problem in 4.13.

I can reproduce this bug frequently.

I’m using Unreal 14.4.2 compiled from sources. I have GTX 460.

In attach the stack which ends with :

UE4Editor-D3D11RHI.dll!FD3D11Viewport::PresentChecked(int SyncInterval) Line 267

In attach you can see the log with -d3ddebug

The operations I do:

  • I press F5 to launch debug of my project in Visual Studio
  • I navigate to Content/ThirdPerson/Blueprints/ThirdPersonCharacter (which is BluePrintClass)
  • I open it
  • In the Class Defaults window I go under Mesh / Skeletal Mesh, and change the ThirdPersonSkeletalMesh with my mesh: kran_baserig_1_4
  • I see the thumbnail getting updated and I see my char there, then black screen for 2 seconds, then the crash pop-up. NVidia tray icon is telling me the device stopped working. I’m using drivers 376.33

The project contains some proprietary art, but I can share it with you under NDA if you think it may be useful.

I can reproduce this 100% of the time (also after full PC restart).
I also have other crashes ending with D3D11Util.cpp Line 176


link text

Hi, I’ve posted a comment to the OP but I want to be sure you also get the notification about my tests, please look up.

Have you clicked on the bug report link I provided recently?

There is a QFE available which was made specifically to address this crash and one another that was very similar. These two crashes were occurring far too often so we decided to push out a QFE to have them addressed. It will also be addressed in the hotfix.


Hi Andrew, sure I’ve seen it, but I’m using 4.14.2 compiled from sources, for this reason when I launch the hotfix it says it cannot find an unreal installation. I discussed about this issues also here: Unreal Engine is exiting due to D3D device being lost (Error: 0x887A0006 - 'HUNG') - World Creation - Epic Developer Community Forums . Where Ed suggested a specific code patch (probably the one contained in the QFE?) but this I already have in my codebase, so it’s not solving the issue. in advance for anything you can do about this issue. Its a real pain! :slight_smile:

Me too: Work on 4.13 but no in 4.14 and I have a gtx560TI :confused:

The 4.14.2 hotfix didn’t fix this problem for me (nor did 4.14.3). It still crashes just like before.

EDIT: It crashes a lot more regularly now. It crashes even outside Persona and the Particle editor now.

This fix resolved a number of these crashes, but did not catch all of them with a single fix. Could you provide us with your repro steps to get this crash to occur in a blank project, as well as your ‘dxdiag’ so we can take a look at your system specs?

Thank you,

I will see if I can replicate it in a blank project. Here’s my dxdiag: http://hlssmod.net/DxDiag.txt

Hi all!

There is a possible workaround that we are investigating. The GPU crash may be related to microsoft’s Timeout Detection & Recovery(TDR) feature. You can find out more about it here: Timeout detection and recovery (TDR) - Windows drivers | Microsoft Learn

Basically, it detects if your GPU is hung up and if it passes a certain amount of time Windows will automatically reset the GPU resulting in the crash. This is done to prevent a freeze forcing a hard reboot of the system.

Sometimes you need to add a little more time for your GPU to process before Windows causes the reset. To do this you need to change the TDR delay.

I have two suggestion on how to do this you can do it manually yourself OR you can download a tool that will do it for you. However, I haven’t used the tool that much myself but it does appear to work. (Use at your own risk)

Method 1 (manually):

  • Go to the this link:
    Testing and debugging TDR during driver development - Windows drivers | Microsoft Learn

  • There you will find a section called TdrDelay it gives you all the information you need to create a registry key that will change the delay time

  • To open your registry open your start menu and type “run” once the window is open type “regedit” and hit OK

  • Now you should have Registry Editor open this is where you will use the info at the website I just linked.

  • First navigate the key path HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers

  • Right click on GraphicsDrivers and go to new> DWORD (32 bit) value

  • You will see a new key appear make sure to name it “TdrDelay”

  • Right click it and select “modify”

  • Under Value data enter 10 (this is the number of seconds to delay) make sure you have Decimal selected as the base

  • Hit okay and restart your system

Method 2

Please Update this post if this solves your issue or if it has any effect at all. We need this information to get an idea of what is going on.

Hi all,

It’s been a while so I decided to try the updates and other workarounds mentioned on the forums. The crash is still present on 4.14.3, but it’s harder to trigger it with the original repro steps. I’ve added these additional steps which do produce the crash reliably:

  1. Close the “SK_Mannequin” asset.
  2. Open “Content/Mannequin/Animations/ThirdPerson_AnimBP”.

UE 4.14.3 (-d3ddebug)

result: crash

The original steps were enough to trigger the crash. However, it’s harder to reproduce the issue that way. Following the additional steps reproduces the crash reliably.

UE 4.14.3 (-d3ddebug, TdrDelay set to 10)

result: crash

The modified steps were enough to trigger the crash. It took longer for the display driver to reset, and editor appeared frozen before the reset.

UE 4.14.3 (-d3ddebug, NO Real-Time Thumbnails)

result: no crash

The modified steps did not trigger the crash. Even heavyweight things like rebuilding lighting, opening multiple blueprints, materials, etc. couldn’t trigger a crash.


Open the editor, open the Content Browser, select View Options (eye icon bottom right), and uncheck Real-Time Thumbnails.

Source: here. Thank You: IronicParadox

UE 4.14.3 (-opengl4 -opengldebug)

result: no crash

Note that -opengldebug is optional, and is the source of some verbose logging. The editor ran fine using only the -opengl4 flag and did not crash.


Create a shortcut to UE4Editor.exe. Edit the shortcut’s properties, in the Target field add the -opengl4 flag:

Target: "C:\Program Files (x86)\Epic Games\4.14\Engine\Binaries\Win64\UE4Editor.exe" -opengl4

Source: here. Thank You: Gereksiz

I couldn’t attach the logs to the post above so I’m adding them here instead.

UE 4.14.3 (-d3ddebug only) Callstack

UE 4.14.3 (-d3ddebug only) Log

UE 4.14.3 (-d3ddebug, TdrDelay set to 10) Callstack

UE 4.14.3 (-d3ddebug, TdrDelay set to 10) Log

The -opengl4 one seemed to work for me. Or at least so far it didn’t crash when opening the same animation that crashed it before.

EDIT: my display driver doesn’t crash anymore, but I sometimes get another crash altogether.

If you are getting a separate crash feel free to create a new AnswerHub post so we can investigate without all the clutter.