Unreal Engine 4.12.5 freezes

I have a problem with my Unreal Engine 4.12.5, it freezes (no crash or bug reports, Windows working fine, only UE4 freezes) no matter what i do, usually from 2 to 10 minutes after startup(even if ue4 is minimalised).
I checked it already with 4.11 and 4.10 and they are working fine, i tried using verify option and it helped but problem returned after few starts of UE 4.12.5.
I did not had this problem in 4.12.4.
System: Windows 10 pro
Let me know if you need any files or info to investigate this problem.

Hi ,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this error on my end?
  • Are you seeing a large memory spike during use? For instance, if you leave the windows task manager open with UE4Editor Selected, what is the memory use at the beginning, during, and once the editor crashes?
  • Can you post your dxdiag so I can take a look?
  • Have you tried verifying your engine build by going to launcher>library>engine version dropdown context menu>Verify?
  • Can you post your crash logs here from the next time the editor crashes?

Hi ,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing the error, please comment with the requested information?

Hello ,
Sorry for late reply, I was on vacation.

  1. Yep, but only in 4.12.5 version, after verify it’s working for few days and then problem strike back.

  2. Sorry but I have no idea, it’s just there, only on 4.12.5, no matter what i do or how i use the editor.

  3. At beginning stable 637,6 in editor, during play simulation 647,2, once ue4 crashes it’s usually 655

  4. List item yep

  5. Yes, after verifying it’s working well, but only for few days.

  6. There is no crash logs, UE4 just freeze, i can close editor only by windows task manager, after next startup there is no information about bad exit, lost work or anything.

Hi ,

I have a few things to try.

  1. Please ensure that your video card drivers are up to date.
  2. Check your firewall settings to ensure that both the editor and SwarmAgent are set as exceptions.
  3. Try completely uninstalling and reinstalling the editor.
  4. Run a virus scan. While this is the least likely error, it would be good to rule out a malicious program interfering with the editor.

Once you have run through these steps, please let me know if the problem persists and we can continue trying to nail down what is occurring.

Hi ,

  1. I did update the drivers to newest version.
  2. They are :slight_smile:
  3. I did it too
  4. I scan entire system with Bitdefender and it’s clean

The problem disappear after this for some time but it’s here again, only verify helping but not for long.
I even tried build a game with 4.12.5 and the game freezes too! I did some test on other PC and laptops and it’s working fine, so it’s problem with my system/pc. But why it is only in 4.12.5? I made some test with 4.11 and 4.13 and everything is fine there. I don’t know what to do anymore, i’m going to put my project into 4.11 or 4.13 and wait for 4.13 final release. If you have any idea then let me know. :slight_smile:

Have you checked to ensure you have VS 2015 or VS 2015 redist?