Unreal Engine 4.11 Preview

I havent reported it to AnswerHub as I thought it might be covered by the open ticket already…

Here is a short demonstration of the effect. I can reliably reproduce this behavior.
At first glance I was able to sort of create a material instance struct member as well, but then again not. The error is somewhat peculiar.
I made a short video demonstrating the issue (before writing a whole wall of text).

It shows you a couple of crashes. Sometimes when the member is added, sometimes when a value is assigned. sometimes just by closing and reopening the struct editor panel.

If you need any more info (like the project files, etc.) let me know :slight_smile:

Thanks for looking into this.

i have the same problem with struct like a write few post ago. Seems very evident and easy to reproduce despite seems being random.

Hey Tim,

Thats the post for the build issue.

I think I had a “derp” moment. I just tried the material instances and not using the BP structs that were listed in your quotes. This may have already been reported, but I’ll dig into it tomorrow morning and let you know.

Thank you for the clear details and demonstration. :slight_smile:

In the Paragon Unreal Engine video: - They talk about translucency causing problems with intersecting cards for hair.

Does anyone have an example of how intersecting cards using translucency look bad in UE4 when they intersect?

The reason this would look bad is because with two intersecting translucent planes, one would draw incorrectly on top of or below the other. The whole plane draws basically at one depth in comparison to the other intersecting plane, so even though it should be on top and below the other at the same time, because it crosses through, it in fact only draws either on top, or below, depending on their respective depth. So also, because of this, at various angles it might pop back and forth as you move around it.

Where should I post some feedback for the Sequencer tool? Here or in the feedback section?

I tested the last preview and sadly I see that this problem C++ AMP is no longer working - UE4 AnswerHub is yet to be fixed. Is there any hope to see it resolved in 4.11? The last working version is 4.9, which runs only in VS2013.

I have a static mesh variable with a default mesh and another with default float and notice sometimes reset to “none”/0.0 and must change again to the correct default value. I will report if i doing something special for that occur. Since yesterday i have this small problem two times only.

Not trying to sound repetative though I have yet to see if someone has answered my question or pointed me to an AnwerHub link. Has anyone gotten Substance Plugin to work in 4.11 P2? I tried to compile it with 4.11 P1 like I have done with prior vesions of UE via source but as soon as it hits the Substance Plugin it kills the build. With custom versions or even source for a marjor release that didn’t have the “Marketplace” plugin I was still able to compile it be it official or a custom version based of a stable release. If someone could point me to were I need to go if it has been “fixed/added” I would be very greatful since a lot of the assets we have that are useable/rigged models use Substance Shaders and loading them with out Substance they look like they are Unlit or how models looked when people were able to mod Doom III to run on old Voodoo II/III cards and everything is washed out.

Hey Klaus,

I was able to see this one has already been reported with UE-25449 and a fix was submitted yesterday. This should be verified soon.

Thank you!

check this page, it shows some cases:

the ones on that page show some hair that isn’t too complex. the hair from the robot dude in the paragon video would have these glitches all over the place

add Russian language. pleas … it is very difficult to work in a foreign language.


We have just released Preview 3 for 4.11! Please view the Known Issues List on page 1 of this thread for the updated list of known issues.

Thank you for your continued help in testing the 4.11 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.


Fixed in Preview 3 - CL 2829568

Fixed! UE-24810 Exponential Height Fog is not working
Fixed! UE-25137 Linux platform does not appear in Windows Binary
Fixed! UE-24260 Crash launching on Nexus 5 running 4.4.2
Fixed! UE-24132 HLOD crash when reopening a level
Fixed! UE-25070 Crash when overriding an animation in a child Anim Blueprint and then undoing
Fixed! UE-24403 First Person Template character no longer follows HMD rotation in VR
Fixed! UE-24714 Graphic corruption loading particles on Mac
Fixed! UE-24789 iOS Platform not found when packaging
Fixed! UE-24716 Crash occurs selecting to open Session Frontend or UFE on Mac and Linux
Fixed! UE-25268 bUsePawnControlRotation not working with VR
Fixed! UE-25057 Text variable types in BP Structure cause crashes
Fixed! UE-25352 Crash when loading ‘GDC_KiteCine_Map’ sublevel of GDC_Landscape01 in KiteDemo
Fixed! UE-24736 r.UseShaderPredraw needs to be reenabled
Fixed! UE-25424 Text shaping doesn’t work on the Mac
Fixed! UE-25407 Remove unneeded reformatting of clang error output
Fixed! UE-25371 Loc is gathering from transient properties and objects
Fixed! UE-25322 Setting SupportedAgent’s NavigationDataClass in Project Settings does nothing.
Fixed! UE-25128 Error when AT_MaterialFunction asset is opened
Fixed! UE-25115 No assets are created for static meshes in the level when generating LODs
Fixed! UE-25050 SideScroller2D BP and Code player can fall off sides of the map
Fixed! UE-24974 Baked shadows from static meshes that fall on dynamic objects cause artifacts with instanced stereo on
Fixed! UE-25372 Font cache can crash if the culture is changed mid-frame
Fixed! UE-25016 Custom Depth not rendering with mesh unless it’s selected.
Fixed! UE-25035 Vehicle Code and BP templates have a missing texture
Fixed! UE-25204 Shader Complexity view mode not rendering correctly
Fixed! UE-25041 Landscape content has assets saved with empty engine version
Fixed! UE-22839 Custom Component Being Added to Wrong Target Blueprint
Fixed! UE-25361 UE4 Prereqs MSI does not install MSVC++ 2015 Runtime
Fixed! UE-25109 Player spawn point is incorrect in Third Person and First Person code template
Fixed! UE-23717 Ensure removing an implemented interface when transfering functions
Fixed! UE-25338 Crash playing level sequence after changing blueprint material
Fixed! UE-22845 Trigger Volume Blocks First-Person Template Projectile
Fixed! UE-22910 World Context Object Pin Appears on Nodes After Refresh
Fixed! UE-25498 Crowd simulation state is not set correctly

REMEMBER: Please report any new bugs you find to the UE4 Answerhub

hell yeh fixes for the kitedemo, so does this fix opening the kitedemo and just getting a black screen??

lol launcher ask me for 16gb free space. That a huge fix of bugs :stuck_out_tongue:

its always asked for 16gb free space tho?

first time i notice, perhaps because i only have 15gb free space

yeh lucky u, i only have 250 gb ssd and just opening the kite demo and letting it d=render materials dumps like 20gb of textures into the engines cache :confused: all in all ue4 4.10 with the kite demo is around 50gb for me :confused:

i work with a 120gb ssd :stuck_out_tongue: