Download

Unreal Engine 4.11 Preview

My simple project on android lost 12 fps . I had 32 on android samsung samsunggalaxy 3 Now it is 22 .
It happened after prewiew 7 .
Do not install prewiew 6 just immediately jumped from 5 to 7 .
The situation is similar on ios .
I only use Blueprints
I’m using UE4 Launcher version.
HEEEEEEEEEEEEEEEELLLLLLLLLLPPPPPPPPPPP !!!

No way, let them make it shiny and stable thanks.

I put it up in answerhub:
https://answers.unrealengine.com/questions/392995/could-not-find-set-bfollow-hmd-orientation.html

Hmm with preview 8 Im now getting a Level Blueprint error:
The action “Set bFollow HMD Orientation” with Get Player Camera Manager as target now results in the following error:

Could not find a variable named ‘bFollowHMDOrientation’ in ‘PlayerCameraManager’
Make sure ‘PlayerCameraManager’ has been compiled for Set bFollowHMDOrientation

Im not sure if my VR setup will still function the way i want to without this element. Will need to test this.
I asume something has changed to the engines PlayerCameraManager in preview 8?

This is actually a change from 4.10 to 4.11, in 4.11 epic moved the “Follow HMD Rotation” bool from the camera manager to the camera component as “Lock to HMD” which is nicer because it also locks the hmd position as well. This means we can get the world rotation and position of any HMD a lot easier now.
Shameless plug I have a video on the difference between 4.10 and 4.11 in regards to Follow HMD Rotation here

And now hot reload is broken ;(

The console commnad : SP.PanoramicMovie its not working anymore as in preview 7 , whats going on about this ?

https://answers.unrealengine.com/questions/351910/how-to-ignore-self-shadow-in-mobile.html

UE-26765 fix it?

I hope this isn’t the last preview to be honest, I’m still running into a lot of walls and instability compared to 4.10.

Answerhub is down for me again (I give up with that website), so I’m posting issues here for now.

OBB Fails to download from Google Play Store
We’re currently on the verge of sending out download links to our alpha testers and we’re distributing through the Google Play Store, and have been testing the process in office all week. We’ve opted to upload the .apk to the store, and the .obb file as an expansion file so that the download size is relatively small on the store. Unfortunately, it doesn’t work.

What’s supposed to happen as far as I can tell, is the user downloads the .apk from the store, then when they launch the game - it tries to find and/or download the .obb file. If you do this though, nothing actually happens. The progress bar goes nowhere and all we have on-screen is a message saying something along the lines of .XAPK failed verification - whatever that means. HOWEVER, if I close the app and wait a few minutes then launch it again, it opens up fine. Clearly the .obb is downloading but the game never launches once it finishes or shows any progress.

So what we’ve had to do, is check the box in Project Settings -> Android called ‘Disable verify OBB on first start/update’. This seems to make the .apk and the .obb download directly from the store in one go (which for us is currently 288mb and counting). We could live with that, but here comes problem #2:

For some reason when we download the game from the store, we cannot log into google play services. Works absolutely fine if we deploy directly to the device though. Going through LogCat, we found an error relating to a project number, but the project number does NOT match the one the project is actually linked to and when we click on the link, that project doesn’t even exist on the developer console. We’ve searched everywhere and can’t find a reference to this project number at all, so where is it coming from?



03-23 15:32:08.928  2065 28028 E SignInIntentService: Access Not Configured. Google Play Game Services API has not been used in project 608941808256 before or it is disabled. Enable it by visiting https://console.developers.google.com/apis/api/games/overview?project=608941808256 then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry.


Preview 7 and Preview 8 are the only builds we’ve tried this on and both have failed. We can’t revert now and have no clue how to fix either issue. Not to give away our project ID, but ours actually starts with a ‘4’

Hi,

we found a problem with the back button in GearVR when switching activities from On Pause to On Resume. It is broken and it just crashes the app. Link to the complete info here:

https://answers.unrealengine.com/questions/393421/4110-preview-8-critical-gearvr-build-crashes-after.html

Fixed UE-28434 and much more! Very nice work!
Thank you again for your determination to make Unreal always better.

Hey TheJamsh,

Sorry the Answerhub’s still not working for you. I’ll see if we can try to help troubleshoot this Android issue with you, but this thread isn’t the place to do so. Can you please make a new thread in the Android Development forum, and then PM me the link?

Cheers

MaterialEditorStats:Error: Error [SM4] ../../../Engine/Intermediate/ShaderInCED35FE8F44D2E8B172C009F39FABFB5.metal(0): No such executable

Hi,
I keep getting a bunch of the messages on Mac Version of Preview 8. I’m on OS X version 10.11.4.
None of material will work…

Well guys looks like that bug in the 4.11 last preview is even poor and happen in all type of cameras.

And I reported another problem at import a 4.10 project start the problems, looks like is using the resources from the old project and no the imported one https://answers.unrealengine.com/questions/393546/unable-to-generate-long-package-name.html

Hi,

Thanks for new UE4.11 preview 11.

Can you add some button on Re-targeting Bone from Manequine to be automatic T-Pose from A-Pose position. Its give us easy.
Some bug’s preview at the UE4 asset marketplace when you try zoom or full screen the image can’t close.

Thanks and more power UE4 staff

Just for clarity - Important Known Issue: UE-27673 - Mac crashes when building lighting - only affects users running El Capitan on Nvidia GPUs as UE4 will use Metal for rendering when available. This bug does not affect users running on Yosemite (10.10) as UE4 uses the older OpenGL renderer on that OS.

In preview7and8,the editor will always freeze while compiling my player character blueprint…
Here’s the link:https://answers.unrealengine.com/questions/393761/411p8-bugeditor-freezes-while-compiling-character.html

SetTextureParameterValue node for changing the texture of a material instance from the blueprint is still completely broken. I think this problem related to UE-25097.

Did UE-28675 make it into Known Issues list to be fixed for 4.11 release ?

Created a new Bug Report for this problem: SetTextureParameterValue node is not working anymore - UE4 AnswerHub

If release comes out with Oculus 1.0, can we still use DK2 for testing, or have to get release versions of Oculus Headsets?