Unreal Engine 4.11 Preview

What I wonder is why the preview builds are in the release branch on github if they aren’t stable (at least not stable enough to ratify people using it in production) or contain some crucial fixes like some have reported here.

I’d probably go with a separate preview branch to avoid that people keeping their games on the presuming stable release branch (in order to keep it on the most recent version, not bothering with different major engine versions) to be welcomed with a preview that might breaks things (and given the issue that assets can’t be downgraded once upgraded to a newer version, only trough replacing the files with backup files which is very annoying).

Google Play Services don’t work properly because of bug in ValidateGooglePlay() in UEDeployAndroid.cs file.

It always validate fail and show string: “WARNING: GooglePlay Games App ID is invalid!” even if App ID is properly provided.
Most likely it occurs only if I provided long Google Play App ID and this method:

int.TryParse(AppID, out Value)

exceeded int32 range.

EDIT: fix!

Change int.TryParse() to Int64.TryParse()

:slight_smile: :slight_smile: :slight_smile:

Thank you. You are correct, it was rejecting larger app ids. I have applied the fix for 4.11:

When I click “Generate Visual Studio project files” it generates VS2013 files not VS2015.

I just noticed that using a “Material Instance” type also causes the editor to crash…

I noticed the same thing.

A workaround is to use the bat file to generate and ultimately build the editor with VS2015. Then start the editor itself and via its open project menu the project. Next, from the File menu you choose “Refresh Visual Studio Project” and that generates the VS2015 project for your project as well.

edit: project, project, project, I think I missed a project in there lol.

But yeah, having a more differentiated way of choosing what should be generated on a uproject level would be a nice feature addition.

hey guys i have this

decal material and for some reason it looks like

after moved to 4.11.p2
how do i remove black ?

ok so far 2x bugs

  1. OSX build doesnt load the editor

  2. Particles dont display in the blueprint editor

hi there,
If isn’t a secret , DX12 will be fully integrated in this release 4.11 or we will wait until 4.12 :wink:

My previous comment is confirmed and AMD Crimson do not work for UE so anyone with shuttering should install old 15.7.1

I wonder why AMD is not fixed this as very critical hotfix.

Correct me if i am wrong but this might be UE-24826 ?

Is the Realtime viewport on?

Im getting problems with exponential height fog. Works in a water river material… but rest of the scene has no fog at all… with 4.11…

This is a known issue with the current Preview 1 and 2 release. A fix was submitted that I tested yesterday (Fri) where it has been resolved. This should be pushed out with the next preview release.

What is a PreCullTrianglesVolume? I see it as something added in 4.11.

Adding variables to a new struct bp, crash, seems randomly but frequent.

When i converted my project to 4.11, something weird happened. Im guessing every material that samples a texture as linear color… has instead been turned to just “color” which causes me errors. I have to go back to all of them and manually switch it all back to linear color.

Damnit… new problem. If i click the build button in unreal engine 4.11 it crashes the editor. Instantly… with the whole send a report a bug message and all that… I tried twice so far… both times instant crash. Sucks. Was looking forward to kicking off a light build to try out this new light build stuff you guys mention is twice as fast… but so far no luck.

“Assertion failed: SubActorMesh->HLODTreeIndex == 0 [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Editor\UnrealEd\Private\StaticLightingSystem\StaticLightingSystem.cpp] [Line: 779]
ERROR: HLODTreeIndex != 0 for ‘/Game/Maps/BathHouseResort_HLOD/Section_GuestRooms.Section_GuestRooms:PersistentLevel.FogSphere95.StaticMeshComponent0’ while processing LOD actor ‘LODActor_39’”

Yeah real time is on

Can someone from Epic confirm if the following JIRA issues have been resolved?

UE-24280 - Replication issue of actors placed in "always loaded" sublevels when seamless travel is enabled - UE4 AnswerHub
UE-24339 - Crash when connecting a Gear VR binary over the network as client & fix - UE4 AnswerHub
UE-24505 - (Auto) asset import breaks after opening an asynchronously loaded level - UE4 AnswerHub
UE-24880 - [Suggestion/Bugfix] Orthographic projection Oculus Rift canvas rendering - UE4 AnswerHub

Thanks in advance!

I’ve tried to reproduce this in a blank project I converted from 4.10 to 4.11 Preview 2, but I’m not able to reproduce the issue.

Can you post both of these issues on the AnswerHub and we’ll look into them and see if we can reproduce on our end to get them reported?

Thank you!