Download

Unreal Engine 4.10 Released!

Well I got no errors or anything just the performance was insanely slow :frowning: which makes no since especially since I have 24GB DDR3, i7 950 and a Titan X. When I get home I’ll see if the C++ Redistributables installed properly. Cause I ended up uninstalling 4.10 cause I couldn’t even add a tree to a “Defualt” scene with out it taking almost 5mins to load a single tree me she then another 5 to load the textures and after it was a slideshow for frame rates. So either I have particial files floating around or something didn’t install right. Cause I got no errors when making it or building the lighting it was just slow as molasses going up a frozen slope and I only had Skype and Firefox open on the forums which in thepastnever effected the performance of UE4

Hey Steven :slight_smile: i got a big problem with the Console command r.motionblurnew, if i turn it on in the version 4.8 it seems ok, no bugs, i can even controll it but in the newest 4.10 version i cant controll it with the postprocess and its buggy as hell…

Hi iuhiuh,

Can you post this to the AnswerHubin the Bug Reports section. Once there we can get it assigned to be investigated.

Please post as much information to reproduce the issue and any images as reference so that it can help use more readily see what you’re expecting vs what is happening.

Thank you!

Tim

I won’t go to the answer hub yet with this because I’m not sure if it’s me or the version.
Has anyone recorded a matinee fly through yet with 4.10?
I seem to be having trouble. Doing all the usual stuff, ticking camera to start on play, setting it as director, setting the paths etc
Just hit Movie and I get a black screen pop up, even trying changing the format from AVI to BMP I get no files created and just a black screen popup? :expressionless:

OK I did a fresh install of Unreal Engine 4.10 and made sure I had the 2015 C++ Redistributales and I made a very simple seen…my CPU spiked to 96% 75 of it being LightMass and then even after LightMass “stopped” UE4 was still locked. Pics showing. Edited the pics so they can be seen better.

Hi Keiyentai,

This would be best served on the answerhub in the bug reports section (link in signature). Please post there so we can assist you more in depth with this particular error. In your answerhub post, please include a detailed description of the error you are seeing, what steps you are taking that reproduce this on your end, whether this occurs in a clean, blank project with no additional content or if it is limited to one project, and your dxdiag.

Additionally, make sure to follow the steps here to see if they address your specific errors:

That was due to a driver bug which AMD has fixed, but I’m not sure if the fix has made it into the latest released driver yet. We weren’t able to find a workaround, so the new driver will be the only fix.

I have strange load time issue with 4.10. I takes now x2-3.5 longer to load my project (with editor) than with 4.9. Before it was around 5min, now over 20. The issue was already in 4.10 previews. When 4.10 was released, reconverted the Project from 4.9.

My comp: i7 2600K, 24Gt ram, gtx780, ssd, win10 64bit. (planning to get i7-5820K and 32GT DDR2400 in week or few)

EDIT: The issue went away after renaming Project folder. Editor loadtime is again 6minutes which is good.

Thank you Adam Davis for the link to the LightMass information. Also I noticed one MAJOR thing that I overlooked and then saw it was a conflict with 4.9.x-4.10 was I had EVGA Precision X on and installed to control the fan settings on my EVGA Titan X. Uninstalled it and installed MSI AfterBurner and now I have pretty much no lag in the editor minus the initial “load time” when grabbing an asset from the Kite and Open World assets. I also found out that in Windows 10 Precision X for some reason uses a Graphic Hook that not only caused issues with UE4 but completely blocked access to the ENB graphical mods for FallOut 3/4/New Vegas as well as Skyrim. Even when I uninstalled it before I could with the latest build it had to force close some reinstalled Windows 10 Apps/Tiles, think it was Note Taker and something else. When I get back home I will reinstall 4.10 and see if Precision was the main issue.

So to anyone having issues with 4.9-4.10 and you are on Windows 10 uninstall Precision X if you have it cause if you don,t you have to Task Manager kill Precision X and the Prevision X Server service running which is way down the list in the advanced view and if you’re not use to killing services with task manager can be a pain. Also if needed I can post this finding as a potential performance issue fix in the AnswerHub/Wiki

Got rid of the long loadtime after renaming Project folder name. All good. :slight_smile:

Anyone experiencing issues with the widget editor? I can no longer edit widgets in 4.10.0 - even opening a blank widget in a newly created project results in a crash:

File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Core\Public\Templates\SharedPointer.h] [Line: 739]

They work fine while PIE, though. Reinstalled the engine twice. Windows 8.1 Pro 64b.

Just to confirm, it’s all peachy in 4.9.2.

AH entry: https://answers.unrealengine.com/questions/333849/umg-editor-crash-on-opening-any-widget-in-410.html

[EDIT] Solution: https://answers.unrealengine.com/questions/327412/assertion-failed-isvalid-filedbuildfarm.html?sort=oldest

Having problems with brushes and rendering in 4.10. Not sure what the issue is, but character materials only render flat in 4.10. Lighting seems busted and or much brighter than it used to be. Some brushes have had their faces flipped, others downright won’t work properly and become halfway invisible. I had hoped that 4.10 was a stable release, but this seems far from it.

has the noise and flickering been fixed? replaying the infiltrator and kit demo is unbearable right now with the amount of noise flickering on the screen and on the character’s hair. we need AA from pre 8 back

@ Sentura Did you port an older project from a different engine version over? I had similar lighting/texture problems when bringing older projects into newer versions, so I tend to stick with one engine version, or recreate from scratch if moving to a new release!

aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

Since 4.7 materials aren’t functioning as they used to. Any reason for that?

Simply take a look at this screenshot below. With this simple setup they aren’t even compiling, and didn’t reach the limit of 16. Not even close.

4.10 have been superb so far. There is noticeable FPS boost and playing big map (~4km^2 with 14000 actors and ~2million foliage) in editor starts without big delay. Had to use small testmap before to tweak animations/AI but now its fluent also the big map. :o

so far 4.10 has really messed me up… i cant build lighting at all… tons of problems… Fails right when you click build … though swarm agent continues running with a progress bar, but the editor already failed… And if i try to use swarm coordinator with otehr agents… it will even kick me out of the unreal edtior… like instant no message crash.

Hi kurylo3d,

Have you reported this to the bug reports section of the answerhub (link in signature)? We will be able to assist you more in depth there. With your answerhub post, please include what the exact error you are seeing is, what steps you are taking to reproduce this on your end, and if you have tried this in a clean, blank project with no additional content. Additionally, check here to see if the steps provided help you:

Have you tried covering the landscape tile with a single paint layer? If so and this still does not fix the error, please post this to the answerhub in the bug reports section (link in signature) so we can assist you further. In your answerhub post, please include the image above, what steps you are taking to reproduce this on your end in a clean, blank project with no additional content, and whether you are using height blends/alpha blends on the blend node in the image provided. The resolution makes it extremely difficult to tell what each layer setup is.