Unreal Editor won't launch (OS X)

Greetings Unreal Team,

I cannot get editor to launch on my MacBook Pro (late 2013, 2.6GHz i7, 16GB, GeForce GT 750M 2GB GDDR, OS X 10.9.2).

Unreal Engine.app launches fine, but when I push yellow Launch button, editor comes up very briefly with project selection screen, and then disappears. It leaves no trace in system logs (via console), and logs in ~/Documents/UnrealEngineLauncher/Saved/Logs have nothing interesting. Verifying install succeeds 100%. visible version number is 4.01.

Any help you can provide would be greatly appreciated! It works fabulously on my Windows 8.1 PC, but won’t launch on my Mac.

Additional info: if I click on “open” link next to “Content Examples,” editor launches very briefly, with pinwheel, then also exits silently.

Aha…narrowed it down further. If I unplug my second monitor and work directly on MBP Retina display, it comes up just fine. But with my second (30" Apple Cinema Display @2560x1600) monitor attached, it refuses to start.

I get same silent crash on a 27" iMac i5 2.8 12GB OS X 10.9.2. Removed cable for my second monitor and restarted but crash still occurs. Unreal Engine Launcher loads fine and I also get quick flash of editor if I choose one of example content projects then it disappears. Any ideas would be appreciated and me know if you need me to send a sysinfo report.

Hey jonthomason,

Is your monitor connected via USB? If so, you might want to try patch found in this answer:

Hope that helps!

This indeed fixed it! problem was that I had a Wacom tablet attached to my monitor’s built-in hub. Disconnecting monitor, of course, disconnected my tablet and then everything worked. Applying patch from thread makes engine boot without removing tablet. Thanks!

As mentioned below, USB patch below fixes problem. In my case, it was indeed a Wacom tablet connected via USB hub on monitor. Either removing tablet or applying patch works for me.