Unreal editor stuck loading at 75%

My unreal editor gets stuck at 75% when I try to load my project up. I’ve tried deleting
my binaries and intermediate files and recompiling the entire solution in visual studio but it still doesn’t work. I don’t think it’s compiling shaders because it’s not using any CPU or GPU when I look at the process in task manager. But the reason it hangs is always different, each time I try to load up the project. Sometimes its “verifying objects”, sometimes it verifying some kind of Niagara file (as shown in the picture), sometimes it’s “compiling blueprints”, etc. Regardless of the process it says it’s doing, it always hangs at 75%. Is there a solution to this?

I have the same issue. Have you tried:
• Opening the .uproject file from your computer directly
• Opening the project directly from Epic Games Launcher
• Launch Unreal from the Epic Games Launcher and then select your project from there and launch it

These worked for me.

Sadly none of these worked for me

Do you have enough disc space?

I have my project on my secondary drive, which has 820 GB free, but epic games launcher is installed on my C: drive which is nearly full. I could try deleting some stuff from my C: drive to see if that fixes it

I now have 150 GB free on my C: drive and it’s still not working

-Since now you have some free space - try waiting for at least 30 minutes for the editor to launch

-Delete Saved folder

-If nothing helps - you can copy-paste the Content folder into an empty project

you can look in the log file and see if it’s doing anything. or launch it from a command line with the -log parameter and it will open a window with the log, so you can s ee what’s happening in real-ish time.

I tried these, but when your final suggested solution didn’t work (copying the Content folder over), it gave me an idea. I just went through and deleted a few of the different blueprints I most recently made in the project, one of them being a “GameMode”, and deleting that seemed to fix the issue. Thank you for the tips!