Unreal Editor Stuck at 83%. Won't Start

Hello, I am new here, first time I downloaded UE. Everything went well with the download of UE 4.10, but when I click to launch the engine the loader gets stuck at 83%

I tried killing it and opening it again, but the same thing happens.

I am on a MacBook Pro 4GB RAM. Is there anyway I can check if my system is compatible with UE? Might that be the problem?

Any tip will be appreciated,

Solve it! Apparently this was a UX bug. When I launched the editor using Epic Launcher it looks like a new message appears at 83% saying “For best performance use at least 8GB RAM”

The was that that message was nowhere to be seen unless you rightclick on the Editor icon on the dock and find it there.

Once I clicked OK I was able to complete the launch.
Hope it helps.

I had the same issue and solved it by closing the epic launcher, which froze for some reason.

1 Like

so 2023 and if leave spaces in project name and 'open copy from 4.27 to 5.1, same problem stuck at 83%

so i removed the spaces in project name
and then it worked


It worked!Thanks a lot!