Unreal Editor runs fans loud in computer

My computer isn’t the best build possible today but it definitely isn’t weak:
CPU: Intel Core I7-4770K @ 3.50GHz
GPU: NVIDIA GeForce GTX 770 2GB (OC version)
OS: Windows 7 Ultimate 64-bit; RAM: 16 GB
Another thing of note: I’m using a dual-monitor setup, one is plugged to the GPU, the other plugged to the motherboard.

When starting UE4 Editor, my fans start running louder and when a project loads, they run very loudly. Changing quick settings to low “barely” drops the noise and limiting FPS to 60/30 and/or disabling realtime helps a little but the fans are still loud.
I don’t think it’s a heating thing because I tried launching the editor after starting the computer after a cool-down period; the fans were quiet while loading things up but when the editor was starting: the fans were blasting.

It’s not so much of a problem when I have other loud things going on around me like a fan or music but when things are quiet, the fans are too annoying for me to keep the editor open for anything.

Is this a common problem or is there something I can do about it?

Man…if only i had a GTX 770 i would listen to its fans every day and night. :stuck_out_tongue_winking_eye:

Turn off Real-Time Thumbnails in Content Browser bottom right corner > View Options if it is enabled, that helps too. Other than that you seem to have done everything you could.

Not in the slightest bit.
I stopped caring and choose to close Unreal whenever I’m not directly using it for long, and am just hesitant to use it anyway because it’s just annoying.
Not annoying that it happens, but annoying that the only way to stop it is to not have it open in the first place.

I only really open it when I have assets and want to try to use them, want to see if I can do something, or there’s something I need to do in it.

If YOU find a solution, can you let me know? I would try to use it more often if there were a solution to this inconvenience.

Have you guys enabled Use Less CPU When in Background in Editor Settings > Miscellaneous > Performance?

I have this problem badly as well.
Did it really help to turn off real-time thumbnails?

I didn’t.
I enabled it and view framerate and memory, but the issue isn’t/shouldn’t be the CPU, it’s the GPU.
My CPU runs at less than 30% with it running; when I did a test, my GPU (if I recall correctly) was maxing out on usage (or just running high) while not really doing anything, like say I zoom in at a small enclosed area in Flat-shading (a very lite task), it’s still running hard.
It’s as though UE4 is caching a lot of the GPU “JUST IN CASE” but not (if ever) using even half of it.

Enabling this only helps for when you’re not “in” UE4, but obviously it does nothing for when you would actually care the most (that is when you’re actually using it.)

With it disabled, fans run high in and out of editor, but not without editor.
With it enabled, fans run high in the editor, but not out and without editor.

Are you suggesting I raise minimum CPU fan level to above 35% to use UE4 without loud fan (I don’t know where it’s at right now)?

I also have this problem. While the editor is open and not minimized the GPU is just getting hammered with something. I play BF3 / 4 on high setting (for hours) and my fans dont run like they do with UE4 open. My solution while trying to get the editor to be productive is headphones or to open a window to the 20 degree air outside. I never walk away with the editor window up for fear of coming back to dead computer.