Unreal Editor keep crashing at 71%

I’v been going through this problem for the past three days with no avail. I tried everything, I deleted Build, Intermediate, Binaries folders and re-genrate them by right clicking in the .uporject file. Also, I’ve tried deleting them and then opening .sln file and doing re-build and nothing changed.
The latest change I’ve made to the project is added a c++ component, and then added another c++ component [ stupid thing to do as a newbie ] I realized that the component is a class that every object can make use of it by simply ‘instantiating it’ so I deleted the last one and re opened the project I watched some videos of the Unreal Engine 4 course, I updated the project to get the Owner Name. restarted the machine. After running the unreal editor the hell begin.

The C++ Component is called PositionReporter, I thought each actor should had a newly created c++ component [ which is just so stupid ] so after creating a new c++ component. I deleted it -as all actors can make use of Position Reporter component without the need to create new one in C+±. closed the unread editor, restarted the machine. And the Unreal Editor now keep crashing at 71%.
Should I upload the dump file or any report file to help me solving this issue?
Thanks in advance.

Are you attaching the c++ component to blueprint actors? If so, the blueprints may be corrupted. I had an issue similar to this, and it was a real pain to get working again. Essentially, what I had to do was delete the blueprints that had the offending component from your content folder.

I’d highly recommend making a backup of your content folder (Another of the entire project too) before trying this

If the project opens, you basically have two options.

  • Rebuild the blueprint actors from


  • With project open, you can copy the
    blueprints back into your content
    folder, copy your nodes and such into
    a new actor before deleting the old
    one again. Keeping the blueprint will trigger it to freeze again next time you open the project.

Anyway, I hope this helps! Try not to pull to much hair out! If you’re working from a tutorial, it may be more cost effective to start over, unfortunately.

Yes, I’m applying a tutorial example. I did start over again, this is the only option available. And I still don’t know what happened. And no, I didn’t use blueprint at all. Thank you so much for your reply.

No problem. If you’re still wanting to try to get the old project working, the next thing I would try would be to try and rebuild from the .sln file in visual studio. If the build fails, I’d wager that you still have references to the component sitting around somewhere. Another thing id recommend is installing c++ editor symbols by selecting the options for your engine install in the epic launcher. It’ll add like 12 gigs to the install, but at least now it’ll tell you what’s happening in the crash report. You should be able to use that that to pinpoint which line of code it’s crashing on.