Download

Unreal Editor is not responsive

Hello, I’m new to Unreal Engine. I have a problem with the editor, most buttons and menus do nothing when I press them.

Here are the things I did lately, maybe you’ll see something strange and be able to help me out.

After 1½ months of reading/video tutorials about Unreal Engine and Blueprints I’ve decided to start my project. I started with something simple, a small map with terrain and foliage, then a main menu with UMG.
But then I noticed that the construction event is not triggered while in the editor, ie: widget should generate Text objects based on an array, but I don’t get live preview in the edito. In game it works.
So I found this tutorial: https://wiki.unrealengine.com/UMG_Previewing_custom_UserWidgets_in_realtime. Looks simple enough, but Unreal can’t add the files to the project …
I found that I need to generate the visual studio project files: right-click .uproject in Windows Explorer and select “Generate Visual Studio project files”.
I implemented the code as suggested, build, nothing compiles.
Then I found this other tutorial https://wiki.unrealengine.com/Extend_UserWidget_for_UMG_Widgets and followed part #5, 7, 8, and 9 (I think #9 goes in <ProjectName>.h). Everything compiled!!!
I’ve built all configs, just in case, but I think I only needed “Development Editor” for now.
I’m now ready to create magnificent things and become a billionaire! So I restart the engine version (4.12.5)…

And now the weird stuff happens, menus like “File”, “Edit” and “Window” don’t work, mouse over and click change the color of the menu item, but the menu itself does not expand. On rare occasion it opens after 5-10+ seconds, but then barely works. Right-clicking on a file in the Content Browser rarely works. I can create a variable in a blueprint, change it’s name, make it public, but I can’t change the data type, the combo box won’t open. In a blueprint, if I right-click or drag a wire to add a node it’s super unresponsive (search or expanding an item in the list) or simply does not open at all, but in this case if I mouse over what should be there, I get tooltips like “Promote to variable”. The common thing here is opening a popup or expanding something does not work.

Everything works a few days back, before I started messing around with C++.

Here are the things I tried to fix this:

  • Reinstalled VS 2015 Community on top f my previous installation to make sure C++ was properly installed.
  • Verified that I already have the latest video card driver with AMD AutoDetect utility.
  • Opened old and created new blueprint projects.
  • Created new C++ projects without any new code and recompiled.
  • Installed the engine version 4.13.
  • Uninstall 4.13 and 4.12.5, then reinstalled 4.12.5.
  • Uninstall and reinstall Epic Game Launcher with engine v4.12.5.
  • Rebooted many times.

What I thought of, but have not tried yet:

  • Install older drivers
  • > FORMAT C: and restart from the beginning
  • Burn PC and buy new one

PC specs (really old):
OS: Windows 10 Pro 64-bit Insider Preview fast ring build 14915.rs_prerelease.160826-1902
Video Card: AMD Radeon HD 6770
CPU: Intel i7-2600 @3.4GHz
RAM: 2x 8GB

Windows 10 updates all the time, so I don’t really know if some new update did this.
I don’t keep track of my drivers versions so maybe something updated while I wasn’t looking.

Any help would be greatly appreciated.

Guillaume

I am having the exact same issue as this. File, Edit, Window and Help (including right click, blueprints etc) style menus don’t work, I can see the top windows bar gets a gradient as though something has happened. When the Blueprints menu finally opens, the options that expand to another menu > don’t work but I can see the tooltip for them.

OS: W10 64bit Pro, fast ring
GPU:Nvidia 1080
CPU: i7-3820
RAM: 16gb

Maybe the fact we are both on the fast ring is the issue? I don’t have a another capable computer to test this. Though I want to drop out of the fast ring so may do a format on the weekend if I have the time.

This is a problem with the preview build 14915, the popup menus are invisible unless the editor window is made smaller than the display. I reverted to the previous build (you can do it in Settings > Recovery) and it worked fine.

I can confirm that this is a problem with windows build 14915. Epic is probably doing something very non-standard here because the epic launcher and unreal engine are the only programs that I’m seeing this behavior in.

Hello everyone, this issue has been reported by a couple other users as well on our Answerhub and I’m investigating it over here. I’m currently at a point where I’m waiting on getting the necessary hardware/software to do the testing but I just wanted to let you know that it is being looked at.

This made my day yesterday :slight_smile: Finally someone else has the same problems but with a MUCH better PC than mine so it’s probably not the problem. Then I tried to use the editor while not maximized, it kinda worked for a minute :frowning:
I then tried to opt out of insider preview, but you can only do that if your insider build is a real normal production build … so useful.
Settings > Recovery > Reset (keep personal files) still stuck on preview.
Settings > Recovery > Reset (burn it all) I’ll see tonight if I’m still on preview.
If still stuck, I’ll get an ISO of Windows 10 version 1.0.0.0.0.0.0.0.0.0.0.0.0, I don’t want insider anymore.
[MENTION=36033]Matthew Clark[/MENTION]: Thank you for looking into it, won’t be of much use for me but other will appreciate it.

I agree, and further offer some suggestion beyond reverting to a previous build. Try the hot keys. The issue everyone is talking about is especially annoying when trying to change the view perspective (something I do all the time when moving objects about). Since hot keys still work for this (alt G, H, J, K, etc…) you can get around some of this. However many pull downs and buttons have this issue, so a long term fix shouldn’t be dismissed.

It works up to 14905…BUT this version will expire soon (I think it was September 30th!!) so reverting back won’t help for long :frowning:

The idea about making the editor window smaller sounds nice…need to test that out tonight :slight_smile:

Ok so I guess this is happening again I cannot use my tools dropdown button or File , edit, Window , Help. did any of you fix this?

version 4.23.1
Windows 10
quadro 5000 rtx