Unreal editor is constantly locking up my computer

I’ll tell my tale of woe. It started roughly a couple weeks ago. I decided to download the Conan Exiles editor because I wanted to try and make some changes to the game. Their editor appears to be based off of 4.15. It loaded up, finished it’s asset discovery, then proceeded to compile the shaders and after maybe finishing 1500 of them it froze up my computer. When it say it’s freezing or locking, I mean it’s killing the entire system and requires a hard reset. I fired it up again and roughly after the same amount of shaders compiled it locked again. Opened it a third time and it completed the few hundred shaders that were left over and then the program ran fine. Once I started to browse the files and open some things that required more compiling, it locked up again. This was the theme. It worked fine unless it needed to compile.

So I decided to download the regular Unreal editor and do the things in there that I wanted instead of using the Conan editor. I downloaded 4.17 since that was the current version just over a week ago. It loaded up and everything was working perfect. I started to move some of the files I needed from Conan over to the regular Unreal but because it seems I can’t transfer the uassets such as materials, I had to build the material myself using the texture file. In the process of creating the material, connecting nodes and having it loading and compiling, it froze up. I attempted it a few more times, even testing specifically to see what might be causing it, and it only froze when it needed to compile.

Thinking it might be a hardware issue at that point, I started monitoring my system as it was happening. There was nothing odd going on. None of my hardware was really being stressed all that much and none of my temperatures got to a point that I would consider too high. So I wouldn’t say it’s an overheating issue or anything like that. I didn’t know where to go from that point so I figured just in case something was wrong with my system, I did a complete wipe and reinstalled Windows. It’s currently a new computer basically that is fully updated and I have all my drivers and necessary stuff installed.

I downloaded Unreal, this time getting 4.18 since apparently that has released over the past few days. It got up to the project window where you select a new project and stuff, then it started to compile shaders and immediately locked up. I tried to start it again but this time it locked up when it was maybe 80% done loading the editor. I figured maybe the settings I’m using in my BIOS are screwing with something. It’s not necessarily set up as overclocked, just set up to give me the speeds I’m supposed to be having. But I reset my BIOS which ends up lowering the speeds of everything. This time the editor opened up, it compiled all the shaders, and I thought it was working until I decided to stress it some more and play with some material editing which caused it to lock up.

So to sum it up, nothing I’ve tried has worked. Resetting my BIOS to it’s default specs did nothing. I’ve been searching for this issue and there is lots of people reporting freezing over the past 2-3 years but nothing that has been said helps me. My system doesn’t appear to be getting stressed. Since the computer is freezing every time, there’s no errors or anything being reported and nothing is showing up in the logs. I’m getting no information from the computer’s event viewer besides it reporting that the system wasn’t shut down properly.

The part that is irritating me the most is that I’ve been using Unreal for the past year or two with absolutely no issues. The last time I used it was maybe around April or so and then I reinstalled Windows and just took a break from things. The last version I was using was 4.15 but I’ve also used various versions in the past. Now for some reason I can’t keep it running, or even sometimes can’t start it up without it killing my computer. I’ve even tried to replicate the same system I had at the beginning of the year when it was working by installing the same video drivers and anything else I could think of. The only thing that is different about my system is the various Windows updates which I can’t do anything about.

I don’t know anymore. For the time being, Unreal is completely useless and I can’t work on my projects that I already had going. Either this gets fixed or I have to consider moving over to Unity or something, which I really don’t want to do.

Here is my dxdiag so you can get my system information and stuff. I just took a look through it before attaching and at the bottom in the fault codes thing, it’s mentioning something about a radar pre-leak with UE4. Not sure what that is.

link text

Hello Shayfen,

Just to make sure I understand, at this point, you have tried to create a new project in a fresh install 4.18 and it still freezes? Or are you still trying to open or import previous projects?

Also, can you let me know specifically what temperatures your CPU is hitting before the computer freezes?


Interesting, DXDiag also mentions Windows Defender crashing very often. Have you tried disabling Realtime Protection and see if that helps? Alternatively, check that whatever update Windows is trying to install is actually succeeding?

After I re-installed Windows and got the computer back to a normal condition, I didn’t have any of the Conan assets. So I tried to create a fresh project just to see if it worked. It was locking up just trying to load the editor. Once I finally got it to load, I imported a simple skeletal mesh and it froze after the import. I opened it again and started playing around with a material for it and after awhile of that it froze again.

As for the temperatures, I only watched it maybe once or twice during the compiling part when it was working things the hardest. The highest the CPU went was about 69, which for an AMD processor is normal and that’s also not when it was freezing. It started to drop down and maybe got to about 64-65 and it locked up. Most of the other times it was doing just normal processing so I would guess it was maybe around 50 or so. I have a water cooler hooked up to the CPU with a custom fan profile so I can tell how hot things are based off of the speed of the fans.

On a side note, I decided to check out Unity in the meantime. That program seems to run perfectly fine. Along with anything else I do. Modeling programs, intensive games, etc. For the past like three years I’ve had this computer, not a single thing has given me an issue.

When Windows was doing it’s updates after the install, it was trying to download the newest feature update before it had the other Creators update installed. So that caused some errors with installing stuff. It finally got itself sorted out.

The Windows Defender stuff I assume is because I turned it on even though I was already running an anti-virus. I turned it back off since I figured it probably wasn’t serving a purpose anyway. It never caused any problems and I used to run it like that previously. I’ve never been shown any sort of errors or notifications of anything and that stuff in the dxdiag is the first I’ve seen of anything. The stuff could also be from each time I’ve had to reset the system due to the freezes.

Hello Shayfen,

Thanks for that information.

I do have another question. Do you happen to have Unreal Engine installed on a SSD?

Thanks, Tyler

No I don’t. I only use standard hard drives.

Hello Shayfen,

AMD released a new driver package (17.11.1) yesterday. If possible, could you try doing a fresh driver install using that new driver and let me know if it has any impact on this issue?


You can disregard this topic. Apparently my computer has been overheating. I did some more tests with things and when it gets to that certain threshold then the system locks up and has even been shutting down. Now it seems that the cooler I was using isn’t working anymore since I can’t even keep the computer running idle for 5 minutes without it getting to insane temperatures.

So it’s not a problem with Unreal after all. Was just some faulty hardware that wasn’t quite showing itself yet.