Unreal Editor Instantly Shut my PC Down when taking specific actions!

I’m Using UE 4.12, and I’m facing serious problem with Unreal Editor.

Main PC Specs:

  • CPU: AMD FX 6300 (6 Cores @3.5GHz)
  • GPU: AMD RADEON HD 7700 Series
  • RAM: 8 GB
  • OS: Windows 7 Ultimate (x64)
  • DX Version: 11

Additional Current Information:

  • Unreal Editor and Unreal Projects Location: in the [C: System Disk].
  • HARD DISK PARTITIONS: [C: System Disk] (80 GB free of 244 GB), [D: Local Disk] (161 GB free of 1.58 TB)

I’ve also attached my Dxdiag.txt information in the attachment, as well as I attached the latest logs (which are reported by the editor before the PC shut down) for more diagnosis.

The State: My PC shut down suddenly when using the editor, I take specific actions in the editor, like: Baking Lighting, Compiling Shaders and Materials (Specially this one), and currently it occurs when I Import Objects to Unreal! making using the engine IMPOSSIBLE.

I’ve tried everything and this is so frustrating… I’ve noticed that the editor is using un-usual processing power, as well as memory, so I’ve tried to limit the engine usage of the 6 Cores I have To use only 4 (via affinity in task manager)… but with no success, the state I mention still occurs.

Note that this is happening in whatever project, even the empty ones with only starter contents.

–Kindly resolve this issue for me and let me know if there’s any solution possible for this, I assume the worst case scenario would be rolling back to the most stabilized version of Unreal.

link text

link text

link text

Hello Omar,

When you say that the PC “shuts down”, do you mean that it is legitimately turning off by itself or is it only freezing? If it’s turning off by itself, are you getting any windows error messages/screens? If it’s freezing, are you turning it off manually with the power button or is it only Unreal Editor that’s frozen?

If you are getting any windows errors, please see this page and get information from the Windows Event Viewer. If you can get logs from the Windows Event Viewer and upload them here, this should be able to give us an error code that can point to what’s wrong.

Hi Matthew,
it’s not a windows system shut down, it’s an instant power shutdown similar to when the cores are overheated and the pc is shutting down immediately to recover; however, I don’t get any windows’ error message (neither before the shut-down nor after I start turning on my windows again)… as I noticed that my 6 cores’ temperature are increasingly heating (from 30 to 75) when I start Unreal-Editor (beginning from the project selection window).

I’ve updated my AMD Video card drivers to the latest, and nothing changes :(.
but I believe this occurs when I do specific actions in the editor. like: baking lighting, tweaking with the materials (in real-time), compiling shaders, and Importing Assets. :confused:

but I will try to get an error code this time, and I’ll shortly keep you posted.

Matthew, I’m in the event viewer tab, and I’ve done the method which you provided in your link, but I found many application error instances, the least of them were reported in 11/09/2016 (means 2 days ago but for iClone Application)… shall I select all the instances and save them, then I upload them to you; or just save a specific one?.. please, inform me.

If the computer is shutting off due to the processor overheating, we won’t be getting anything from the Windows Event Viewer so you can ignore that for now. Would it be possible for you to ensure that your cooling for processor is still working correctly? This sounds like a situation where the cooling is failing to do its job.

If you do get a chance, please try reverting to the previous version of the engine that you were able to use previously (What version is that?) and see if you still run into the same issues.

Edit: Also check on your power usage. This could be a power supply failure, as the GPU and the CPU could be using too much power. Processor overheating still usually results in a Windows BSOD but a power supply failure would result in exactly what you’re seeing.

Yes, I believe it’s an overheating issue above all. minutes ago, I started the engine with core-temperature monitor open; and I found that compiling shaders is the cause of the problem, as I get readings of a 85 degree tempreture; after that… the PC power turned off for recovery. :confused:
the awkward thing is that, this never happened with me while Gaming. I run Batman Arkham Knight on Ultra Settings for hours and never had this overheat jump above 85 degree. :smiley: I assume working on the engine is a little bit different. :stuck_out_tongue:

but I was wondering if there are any preferences to insure performance and stability for the editor (like disabling the auto compiling feature, and such?)… by the way, my editor’s version is 4.12.2.

–Thanks in advance.

When you mention disabling the auto compiling feature, do you mean Hot Reloading or blueprint compiling? Both of these can be disabled from the Editor settings windows. I’m going to set my last comment as the answer to this question as it seems that we’ve found that this is an overheating problem. If you do find a solution, please let us know.

Hello again Matthew,
… to be more specific, I meant the material blueprint compiling which cause the jump of overheating to beyond 75 degrees :/, any other blueprints (and hot-reload as well) are not consuming that much of the processing power when compiled (as cores’ temp are mainly between 64 to 72 maximum which are safe temps for me). currently, I’m not able to make my prototype in Unreal Engine using materials anymore, and I’m producing with solid objects (or meshes) instead until I find a fix to this frustrating problem. :’(

is that a bug in the engine?.. because even when I applied the core thermal paste (later on)… and also upgraded my video card driver to the latest, the issue of overheat jump still occurs; either when baking lighting or compiling materials blueprint (shader compiling).

is there any practical solution to this? I noticed that UE 4.13 is released, but is that problem fixed in this version too? because I intend to upgrade the engine if so. :confused:

awaiting your respond. :slight_smile: --Thanks for your interest–

Hello Omar,

From what we’ve gathered so far, there isn’t much information to support it being version specific or a problem with the engine in general. Please keep in mind that the GPU is not related to material compilation, baking lighting, or compiling shaders. It is expected for these processes to put a heavy load on your CPU but the cooling in your computer should be able to take care of this.

If you would like to test to see if it is version specific, I would suggest trying an older version and 4.13 to see if your results differ. Otherwise, I would suggest checking the heatsink on your CPU and ensuring that it is doing a proper job. Monitoring the fan speeds in your computer would be useful as well, to ensure that they’re rising to accommodate the increase in temperature.

It turns out that my cooling system is so generic, and needs to be upgraded. Though, the solution was to cap my engine’s FPS to 30 through executing an engine command, i wrote “t.MaxFps 30”;
It turns out also that my engine was mainly processing in realtime at 120 FPS! which absoloutly requires more processing power, and therefore leads to overheat the processor; But, since I did the cap my Core Temp got back between 30-45 degrees, and That’s cool.

I would recommend the development team of UE4 to upgrade the interface to include the processing fps in the performance settings, so that the user could tweek and diagnose his pc along with his experience with engine.