Unreal Editor gets to 45% and crashes every time

First, I was using Unreal 4 while it was paid, but I haven’t been able to make it work once since it became free. I’ve tried every solution I can find on the internet for the crashing but nothing works, sometimes Unreal gets slightly further than 45%, but it crashes every time. Running Setup and GenerateProjectFiles seems to go well, and so does making the executables, the problem is it doesn’t run like it used to, the Editor doesn’t run at all. I’ve read many posts saying the same thing, Ubuntu is having some issues running the Editor. Is there any possibility of a pre-compiled Editor becoming available for Linux distros like Ubuntu to accurately solve this? I have been losing my mind trying to make Unreal 4 Editor work for weeks now, and all of the fixes I find for this are pretty involved, and I feel I’ve tried everything already.
-Chris

Did you update Ubuntu? It gave me quite a (insert expletive of your choice) of problems until I updated it. If that does not work try Recompiling the engine? I been having a problem with the lighting not building and will try that myself. And about the Editor install working like windows, I think they want to do that in the future. Hopefully really Soon!

So, could somebody please e-mail me a compiled Editor that works on Ubuntu, I’ve tried everything I can find to fix this and I still can’t launch the Editor. I’ll be forever grateful…
Chris
christiedemann@live.com

I would but my internet is a living relic from the early ninties. Here is the only thing I suggest you do. Redownload the source, and build it again. Just look up a tutorial and it should be pretty easy. And what is the size like 5GiG? That is to big for most people to email you. :frowning: Now just a couple a things you should remember.

  1. Do NOT do this in a root user! I made this mistake!
  2. You will need Clang 3.3 or 3.5! nothing else will work!

You probbably now all of this, but just in case. :slight_smile: Also it will work better if this is done on your system! Linux can be a jerk sometimes. Happend with a diffrent program, Gdevelop, My friend compiled the program and it worked great on his computer. But would not on mine. So, probabbly best for you to do it. Hope everything works!

Okay, I’ve made the Editor go further by changing the Editors advanced permissions to launch in an independent window rather than the executable default. The launcher works, but when attempting to open a file the Editor loads to 100% then just stops. I received this error. Any ideas how this could finally work now?[link text][1]

-Chris
[1]: 38502-editorcrash.txt (65.9 KB)

Okay, I was looking at it but, have to go somewhere. :frowning: Are you using AMD or Nvidia video card, change to proprietry drivers. I will look into it.

Okay, I made an attempt at finding the problem. But this is beyond me. :frowning: I had this problem, all I did was change the driver but, Since you are having a new problem, I suggest making a new question. Sorry I can’t seem to find the problem. (beyond my limited knowledge) But what was interesting was that the crash file keeps saying it couldn’t load certain files. All I can say is to make a new question. Hope you find a solution. Have a good day.

As Launcher is not available for Linux yet, there is no Editor binary for Linux.

Also, as far as I am aware, licensing does not permit anyone, except Epic, to distribute the Editor binary, outside the Launcher application itself.

Otherwise, the Editor runs great in Ubuntu - it is our (community) primary target platform for building, as well as Epic’s QA to test it.

Please go back and re-try compiling the editor. Make sure you are using my branch (3dluvr/4.7-linux) to build as that is the one with all the fixes and improvements.

If the Editor fails to start, run it through gdb and then wait to see if there’s a crash that might provide a stack trace.

The issue might as well be with your AMD card and OSS drivers, so as suggested above, please switch to proprietary ones and try again.