Unreal Editor Crashing OS

I need help, I just recently got a brand new desktop machine. It’s an iMac with 5K resolution and a 3.2 GHz quadcore intel processor… I tried to install the latest version of the UE4 Editor, and for whatever reason every time I’ve tried to set up a new project, the editor overclocks either the disk or the CPU, it would seem, and crashes my whole system.

Not sure what’s going on, the CPU should be able to handle the editor… I’m also operating on OSX El Capitan 10.11.5

Specr,

Have you kept open the Activity Monitor, to get some sense of what is going on? I.E. is all memory being consumed? This is in general the way that I have seen the “Editor” have problems, when using Windows, as I don’t have a Mac to work with (but use to do technical support at Apple). Or is the crash so immediate, that you have no time to see anything?

Jay

IceWare Inc.

IwSpline

I select “NEwProject” and I’ve even tried selecting no startup assets in the basic settings of UE4, and yes, I’ve kept the Activity Monitor window up, and the memory, disk, and CPU seem like they all spike? It will say “Initializing” on the UE4 editor, and maybe get to about 60%, it seems like its loading fast, then boom. My entire OS crashed and I had to restart my computer.

When I logged back in, no crash report or anything… not sure what’s going on

My apologies, I should have asked another question, is this a Blueprint based project, or a C++ based project? Which project template are you selecting? Is it just defaulting to “Blank”, and your off and running? or in this case, off and “crashing”?

Jay

IceWare Inc.

IwSpline

I’m going to have to find out, just a minute.

It seems like it was a blueprint project, should it have been a C++ instead??

That I didn’t expect, i.e. that it was a blueprint project, and still crashing when attempting to create a project.

You should be able to create a blueprint project, with nothing else installed, as there are no dependencies on a compiler (i.e. a C++ project needs a compiler installed, the same compiler that Apple provides).

Have you tried any other project templats, besides “Blank” (as that is the default project to create, i’m assuming that is the one you are attempting to use).

  1. Try a different project, say the Third Person Project.

Have you ever been able to create a project? If not, try installing, the 4.10 UE4 engine, and give that a shot. But for now, stay with the Blueprints, no need to inject more variables into this, by trying the C++. The biggest concern is that, this is down in the “guts” of the creation process, as the Blueprint project is blowing up, as well as the “spike” your seeing in resource utilization.

If the Third Person Project, blows up as well, definitely, try installing the 4.10 engine, and see if the same thing is occurring there.

Jay

IceWare Inc.

IwSpline

Perfect answer, thank you jayice :slight_smile:

I’ll give it a try. I’ve never got a project up and running it seems, or the time that the UE4 editor actually opened, the graphics were completely messed and things were still loading up, the screen was all kinds of colours before settling in, and that was the point it crashed at.

Can you also check, that you are using the latest drivers for your video chip? I don’t know which video chipset you have, but the Apple update (unless you have nividia and have been updating the drivers yourself), should be keeping you current if I remember correctly. This is indeed one thing to take a look at as well.

Jay

IceWare Inc.

IwSpline

Thank you jayice, I wasnt able to get version 11 working, but version 10 worked like a charm, hardly no issues. Big thanks again! :smiley:

More than welcome, would be nice to know why version 11 is blowing up though, that’s for sure

Jay

IceWare Inc.

IwSpline