Unreal Editor crashes when compiling or adding new classes

Unreal Editor for version 4.8 of the engine crashes when using the new C++ Class wizard or when trying to compile after changes have been made to source code files from Visual Studio 2013 Community.

Crashing seems to always happen when using the C++ Class Wizard but only crashes when hitting the compile button after changes have been made to source files.

EDIT: Upon testing, this seems to only happen with a specific project as my other projects don’t experience this crash.

Error Log

Hi nossr50,

We have another user who has reported this same issue at the following link: Serialize causes crash - Programming & Scripting - Epic Developer Community Forums
We are currently looking into the issue and hope to have more information soon, but please refer to the linked post so that we can get all of it in one place. You can feel free to comment on that page as well to assist in finding this issue if we have any questions we need to ask or if you simply have more information to provide.


Unfortunately I decided it is best to start my project anew rather than try to fix all the bugs. I first started this project with 4.6 so I thought it was a good time to remake it. I tried looking for solutions but it was really long and tedious, having to step through engine code.

In the beginning the error was coming from spawning my bots. Then as I described in my original post, when I tried editing my Game Mode BP. After a while the crashes resolved themselves despite me not doing anything. The last issue I was able to find was caused by the function Load Game (sorry for not having the exact name) from UGameplayStatics. The serialize at the end was causing a crash as well. This is easily fixed by deleting your save game file and letting the engine create a new one. I guess working with 4.7 save file causes problems.