Unreal Editor 4.7.5 OSX MAC Mouse Issues

The mouse does not work properly on multi monitor systems.

OSX Version 10.10.3
MacBook Pro (Retina, 15-inch, Mid 2014)
Processor 2.8 GHz Intel Core i7
Memory 16 GB 1600 MHz DDR3
Graphics NVIDIA GeForce GT 750M 2048 MB
Apple Magic Mouse (Bluetooth)
Two external 23" monitors connected via display port.

Monitor 1 - Internal Macbook monitor - Unreal editor works fine.
Monitor 2/3 - External - Cannot drag/move objects in the view port, mouse pointer keeps jumping to lower left

For me this makes UE4 totally unusable being restricted to the smallest monitor. A terrible first experience!!

Hello Cakey123445,

This issue was originally reported and fixed back in engine version 4.5.1, but there are known issues with the mouse you are using which could still cause undesired mouse navigation. Would you mind testing a regular wired mouse to see if you are experiencing the same issues?

Also, what resolutions are you running for each monitor?

After having a look at the dedicated GPU you are using, it has support for certain displays up to specific resolutions so be sure you are within the correct resolution range.

Let me know what you discover and if you still need assistance.


Screen 2 & 3 = 1920 x 1200

Same behaviour with a normal wired USB mouse (not working properly)

Resolution range is both supported and selected within the OS normal settings function.

Starting the editor on the MacBook window works ok.
Use the mouse to drag the window up and onto monitor 2.
No longer works to move/drag objects and keeps jumping to lower left
Drag window back to monitor 1
All works fine again.
(Tried & replicated with USB Mouse & Magic Mouse)

Monitor Arrangement is:
2 3

Hey Cakey123445,

Thank you for providing the requested information.

Do you have any external applications running that could be affecting the dragging, and how to you have your set up arranged. I was looking at the display ports on the Macbook we have here and there is a single HDMI and a single Thunderbolt port. How are you connecting all of these together?



MacBook Pro (Retina, 15-inch, Mid 2014) has two thunderbolt/display ports on the left hand side just in front of the power connector. I have two Apple DisplayPort to DVI adapters to DVI cables directly to the two monitors, no other hardware in the way.

Only apps running in the taskbar/backgroun are Dropbox & iStat. Have tried with other apps open/closed, no change in UE behaviour. All other apps work on any of the monitors and have no issues: Photoshop, Android Studio, Xcode, Chrome.

Kind Regards


Hey again Kate,

So I am currently connected to two 1920x1200 monitors using the same set up you have with the Macbook Pro we have here. I created a new blank project and attempted all different types of dragging and dropping with actors in the scene as well as moving tabs and windows around. I was unable to reproduce the mouse jumping you are reporting.

You have given me ample information about the issue and your hardware specifications, so this seems to just be a compatibility issue somewhere with the editor and your specific set up. I will continue to investigate further, but if I am unable to reproduce the issue, I can still enter a bug report so we may find the root of the issue.


After some experimentation I’ve traced the issue back to the screen layout/arrangement, (2 & 3 are the 23" DELL DVI monitors and 1 is the macbook itself.)


With the main macbook internal monitor logically below the other two in the arrangement (mirrors my desk arrangement) I have the problem of not being able to drag/move objects in the viewport, I can drag tabs around just fine, just not actors/objects as described previously.

However if I change the monitor arrangement to:


Everything works just fine, there is definitely an editor bug there.

Kind Regards



I faced the same issue.
If my monitor is set exactly near the MacBook screen it works fine:


Though if I set it higher (like it is in the real world) - I have the same bug:


Hey guys,

Thank you for helping narrow down the cause of the issue. I have gone ahead and entered a bug report with the tag UE-14393. I have added the images you provided for extra visual explanation so we can hopefully get this issue fixed within an upcoming release.

If you have any additional comments or need further assistance please let me know.