UNREAL doesn't like WACOM PENS!!! Huge issue for Hollywood 2 Unreal CGI transplants like myself!

I am trying to switch from Unity to Unreal one of MANY things Unreal makes harder is,. well, anything you click… I can’t get my Wacom Pen’s to do ANYTHING in Unreal 4.19 (or any other) They work fine in Motion-builder, Photoshop, 3ds Max and Autodesk Interactive, Boujou, in ‘TOPAS’ *(joke…) in Unity, in Windows, everything EXCEPT Unreal, YOU left click, nothing happens, You have to reach for the Ancient Mouse Thing! Or you right click, it does something different than a mouse right click (even though they do the same in EVERY other software including all of Windows) I have tried my Desktop Wacom Cintiq, I have tried my Tablet PC Wacom Cintiq Companion II, I have tried my Intuos tablet and my old wireless bluetooth Graphire Tablet, ALL are USELESS in Unreal !!! THAT ALONE is enough to make me pick Unity, even though there is so much that is good (Blueprints ahem,…) I can’t take working 4000x slower with a mouse again like it’s the 1980’s! I keep coming back to Unreal often over the years, CERTAIN they would fix this obvious problem, but the song remains the same,.p.s. IF YOU WOULD LIKE TO SEE A VIDEO OF THE PROBLEM IN ACTION I WILL UPLOAD IT TO YOUTUBE ‘UNLISTED’ SO IT DOES NOT REFLECT NEGATIVELY PUBLICLY! See I WANT to be an Unreal Fanboy but it keeps letting me down!!! "~)

That’s weird, I doubt Unreal is doing anything that would specifically be an issue with Wacom tablets, they just send mouse clicks. I’m sure someone else has tried using it with a Wacom tablet

The clicking part of it should work just fine. I think he’s talking about for brush work like landscape painting. The tablets don’t just send mouse clicks, they also send an “axis” as well. Most of the tablets have 11 or 12 bits of resolution for pressure. You’d need UE to detect that pressure axis and apply it when using brush type tools.

Hey man, Hollywood 2 Unreal CGI transplant here, just want to chime in and say that mouse isn’t ancient and Intuos seems to wok fine.

And allow me to spare you the suspense :), UE will keep letting you down far after you have solved your click problems, in your case it will let you down twice as much because it is biased against those who use pens to arrange blueprints… let alone assemble a level in the editor… OR animate in Max… You use pen in Boujou?? Jesus… that’s a new one.


I would like to add to this - I am using a wacom primarily for RSI and ergo reasons - I find little things in the editor don’t work with wacom pens - such as Content Browser - click on a browser tree arrow/triangle with a wacom and it does nothing, click on the same arrow with a normal pen and it expands the children. This means I have to keep switching to a mouse to do something basic that should just work. I prefer not using the mouse because it hurts.

I can see when I use the Wacom that the click is showing up as the triangle turns black - but the tree does not expand. Using the mouse the same behavior with the triangle turning black is registered, but the tree is expanded.

I don’t think Slate has support for pressure sensitivity.
The whole Editor is built upon Slate systems’ widgets.

Hi People! I am having the “in UE4 not recognized Wacom-Pen issue” to. Im Working on an Wacom MobileStudio 16, and just can´t get the Pen working properly. As it has been said here before, it should actualy work, but the only information that i could find regarding this problem, is that it is currently supported but just for developers?!?! i am Using UE 4.25 i would like to know if some of you could actually make the Wacom-Pen work.

1 Like

im unreal engine file trips when i switch to pen stylus. But when i go back to mousepad I can interact with UI. So trippy.

Try disabling Windows ink in tablet settings and see if it works.

I started learning UE5 about a month ago and yeah, I’m in the same boat as everyone else here. Trying to drag anything in bluprint mode is impossible with a stylus but you can make it work if you map a controller to have left and right click functions. I already had a dualsense, with basically my entire keyboard, as well as mouse buttons mapped and you can get by.

Pro tip, try instead of tapping the stylus to click, do a little swipe to the right or left and it should register as a single click. I’ve found it works for most things. I’m only new, though, haven’t started actually painting landscapes or anything yet…