Unreal DetourCrowdAIController smooth rotation

Greetings, i have my ai working pretty much exactly how i need them, with their janky default detouring and all. With the only real issue being their rotations, as they constantly detour around inside the crowd, they rotate at crazy speeds looking for a new path, this is fine for movement, however they are constantly jittering when it comes to rotation.

I have played with “Orient rotation to movement” and altered the rotational speeds, which sort of helps it a little, but for it to be good enough to solve the jitter, the rotation has to be so slow that it barely rotates at all.

Is there a “finding detour” event or anything that i could use to start a rotation lerp or something? or has any1 got any other ideas in general?

Thanks in advance.

I have the exact same problem…any one…?

I don’t know if you’re still having this problem 3+ years later, but I had the exact same problem and this solution worked perfectly for me:

  1. I made the same alterations as you did on the character movement, turning on “Orient Rotation to Movement” and knocking the default Z rotation speed down from 360 to about 200 (not as general rule, 200 was just the speed that worked best for my game)
  2. Go to the class settings under Pawn and turn off “Use Controller Rotation Yaw”

Whether this might have undesired follow-on effects elsewhere on the AI controller movement, I cant’ say, but it fixed the jittery rotation problem for me.

1 Like

Thank you so much! This helped me with the same issue!

Writing this down so others can see

I had great success getting rid of the jittering by going into “Crowd Manager” in Project Settings. In the first Index, I changed the Velocity Bias to 1 and a lot of my issues with the jittering and the pathfinding were solved! Might be worth checking out some of the other settings in there too.