Download

Unreal Datasmith stuck on 'queued'

I was just trying to update unreal 4.22.0 and it seems dependent on the datasmith updating first. Problem is, the datasmith is stuck in a continuous queued mode. I stopped it. Rebooted. tried uninstalling. Nothing works to get things rolling again. I should point out I have a minimum setup here as I’ve only worked on a tutorial type of game. Can anyone help? What do I need to clear out in order to help this update work properly? Thanks

There shouldn’t be any sort of dependency between whether the engine receives a hotfix update or the Datasmith plugin gets it first. Assuming both are already previously installed, then they can update in any order.

It’s been a few days since your post. Has there been any change?

i have been trying to update 4.22.1 to 4.22.2 all day and it is hanging with “Queued”. Update to the engine initiates an update to Datasmith and Datasmith stays queued and downloads tab shows nothing is downloading… when opening the engine it reports as 4.22.2 (though showing as 4.22.1 queued in launcher) - pick new project (mobile/scalable2d/starter content) then throws up a missing projectname modules window with 8 datasmith modules and four others and the question “Would you like to rebuild them now” pick yes and it fails… try and run the project created and alert box says that this file does not have an app associated with it…

Hello,
I just had the same problem for some days now. You can see bellow what I did yesterday (while watching the live training) to solve mine:
1 - Close the launcher (I needed a restart)
2 - Rename the UE4 folder
3 - Start the launcher again and you should see that you have lost your install
4 - Start a new install, wait for it to begin and stop it (not paused)
5 - Close the launcher again
6 - Copy the content of your previous install into the new folder created by the install and wait for it to finish (do not remove anything from the new folder)
7 - Restart the launcher and resume the download (For me, it did a check with some updates (4.22.2 to 4.22.3) that was quite fast than a new install)
8 - You should have your new version

Hope that helps

Best regards.

Having the same issue here.
finalherizo solution did not work for me.
Had to uninstall EpicGames Launcher, rename old Epic Games directory, reinstall the launcher and then reinstall 4.22.3. Seems to be working fine now.

Last week, I had the same issue.

Today, it updated fine.

I had the same issue.
I just deinstalled the Epic Games Launcher and downloaded a newer version of the Installer Package. Then I installed the newer Epic Games Launcher version WITHOUT deleting or renaming old folders! Just the same place like before and the update worked fine - also with the Datasmith Plugin.