Unreal Crashing with Certain file?

For some reason recently (not sure what I’ve done) one of my files is causing the UE4 Editor to crash.

If I remove the file it will launch.

I also have a back up copy of the file which crashes the editor when I go to open it.

They are pawn blue prints files that reference the same C++ code.

So again I have one that causes a crash when I browse to the directory that contains it and the other will crash when I open it.

Only log I could find was this https://hastebin.com/zabucaciwi.md and it doesn’t seem helpful.

EDIT: For some reason ticking one bool in my PawnBP will cause the editor to crash when it has to (read maybe?) the file. Yet going back via source control to a known working branch and deleting Saved/Intermediate doesn’t help solve i

Hi Nonlin,

Without looking having the Blueprint files to analyze, I cannot say if there is a problem within the Blueprints themselves causing the Engine to crash. However, if they have been working all this time and suddenly ceased working, here are some steps you can try:

  1. Run a Map Check for each level and correct any errors
  2. Right-click the Contents folder in the Content Browser and select “Fix up redirectors in folder”
  3. In your Project Folder, delete the Intermediate and Saved folders
  4. In your install directory, delete the DerivedDataCache folder

Lastly, your blueprint files may have simply become corrupt. If the above steps do not help, try remaking and replacing the Blueprint(s) in question.


Hey , thanks for the input.
I’ve tried all your suggestions and sadly it will still crash the moment I go to the folder containing those BP.

Its a bit of an odd situation. I have another Pawn that uses the same C++ code that doesn’t cause this issue yet this one does.

Last major thing I did was clone my disk to my new SSD which is now my C: everything else is working though and no other file gives issue.

What steps can I take to confirm a corrupt file and if so recover it without losing my work?

EDIT: So I tried an earlier backup from my source control and that too crashes. What could this mean? Although I have two pawns that reference the same C++ code they both use different assets, could that have something to do with it? Really need a way to debug this.

EDIT: So I just reverted back to a known working stable branch and this is still happening. Which is making me think it isn’t the file itself?

Apparently ticking one bool in the blueprint causes the editor to crash.

EDIT: Might also be worth noting that I can play the game still and use the BP just fine. I just can’t go to the directory that has the file and hence can’t open the file.

I agree that if you revert to a known working stable branch it would likely mean its not the file itself, so we will need to take a closer look at the crash data.

Please provide as many of the following as possible:

  1. Your dxdiag (Windows Start Button>(search “dxdiag”)>Launch dxdiag>select “Save all information”>attach text file to your post.)
  2. If the Crash Reporter window is present when the crash occurs, select “Copy Callstack to the Clipboard,” and paste that information in a document and add to this post. Be sure to hit “Submit” on the Crash Reporter pop-up to send the Crash Report to Epic. Also, be sure the text includes your machine ID.
  3. “UE4.log” Located: Engine\Saved\Logs\
  4. “ProjectName.log” Located: ProjectName\Saved\Logs\

So I couldn’t find anything but Unreal Build Tools in Engine\Saved\Logs but I did find a UE4.log inside 4.12\Engine\Intermediate\Build\Unused

I have no Crash Reporter window.

Link to the files I have attachedlink text.

Looking through your logs it appears there is a problem with a plugin. Have you tried disabling all plugins? Also, please tell us specifically what file is apparently causing the Editor to crash.

The file seems to be HiddenPawn.uasset. Only thing I recall doing with the plugins was disabling HTCVive plugin to prevent it from opening every time the editor opened (this isn’t a VR game).

Also HiddenPawn seems to be ok until I tick a bool which is called IsHidden to signify this pawn is a hidden pawn. Other wise its just a regular Shooter Pawn. I’m working off the Shooter Game project, so its a modified version of the AShooterCharacterPawn.

Try disabling 3rd party plugins, particularly, the Substance plugin. Also, try to reproduce with just the HiddenPawn.uasset. and associated blueprints migrated to a blank blueprint project. If you are able to, please send a link to that project on Dropbox (or similar) to me in a private message on our .

Only third party puglin I had was Substance plugin. I edited the uproj by removing the plugin entry for Substance and it still crashes as described above.

I’ll try to get a project over to you as soon as I can.
EDIT: Got a project up and running with the questionable files migrated. I’ll PM you on the fourms. Thanks for the help.

After getting the same result (of crashing) trying to open the files in the Content Browser, I moved the files to a blank 4.13 project and got the following error:


So then I moved the assets into a full UE4.13 ShooterGame2 project and they opened without incident. However I cannot tell where you are ticking the bool “IsHiddent” unless you mean the checkbox shown in the image below:

So, in short, make sure the parent class of these blueprints hasn’t been removed in your current project or you could try creating a copy of your project in UE4.13 (not overwriting the original) and see if that resolves the crash.

Thanks for trying it out but it seems to me that you downloaded a fresh shooter game project in 4.13 and used their default source with my asset.

I modified their source code which added a lot of functionality one being the IsHidden custom bool property.

It seems you have just removed my source and used the default which is how you’ve managed to fix it.

I’ve been suspecting its a problem with my source code but what confuses me is that even after going back to a known working copy with git the issue still persists.

The error message you got is a bit revealing but I still don’t know what the issue is and the issue persists.

EDIT: I just tried creating a new C++ class named TempChar .cpp/.h and then copied over the code from ShooterCharacter into it, renamed TempChar back to ShooterClass compiled everything, opened Unreal created a TestBP derived from the ShooterCharacter, toggled isHidden (custom bool from parent class) compiled and saved with no issue.

Then I tried putting back the original pawn files and it crashes still. Then I tried to open the TestBP and it crashes again. Still not sure what is going on. If it were corrupt BP then a new one would solve it so it isn’t a corrupt BP. If it were a corrupt file then creating a new one would fix that too right?

After looking into this, this does not appear to be a bug with the engine but a conflict in your code which, unfortunately we cannot support on an individual basis. I recommend, using our C++ for support in this case.

Ok, thanks for taking the time to look into this.