Download

Unreal crashes after opening metahuman blueprint

Hi. I had metahumans working fine in 4.26.1. I upgraded to 4.26.2 and also Big Sur on my mac went to 11.4, when I open the metahuman bp, it opens on the graph editor tab and that’s all good but when I click on the tab to see the metahuman unreal crashes and I get a list of can’t find file errors and looking at the logs i think it starts with this getattrlist failed for /System/Library/Extensions/AppleIntelKBLGraphicsGLDriver.bundle/Contents/MacOS/AppleIntelKBLGraphicsGLDriver: #2: No such file or directory

Same thing happens if I drag the bp into the scene. Just crashes.

Thx

2 Likes

Hi, have some problem too (((

…Same thing happens if I drag the bp into the scene. Just crashes…

i have the same problem too

when I drag the bp_emanuel into the scene it crashes…

Fatal error: [File:/Users/build/Build/++UE4/Sync/Engine/Source/Runtime/RHI/Private/PipelineStateCache.cpp] [Line: 139] Shader compilation failures are Fatal.

FGenericPlatformMisc::RaiseException(unsigned int) Address = 0x103736757 (filename not found) [in UE4Editor-Core.dylib]
FMacErrorOutputDevice::Serialize(char16_t const*, ELogVerbosity::Type, FName const&) Address = 0x1038ca673 (filename not found) [in UE4Editor-Core.dylib]
FOutputDevice::LogfImpl(char16_t const*, …) Address = 0x1039d8799 (filename not found) [in UE4Editor-Core.dylib]

I’m also experiencing this. MacBook Pro 2019. I would really appreciate any information

I too face issue. When adding MetaHuman

Caught signal

__pthread_kill Address = 0x7fff203be462 (filename not found) [in libsystem_kernel.dylib]
Unknown() Address = 0x7fff2033f720 (filename not found) [in libsystem_c.dylib]
Unknown() Address = 0x7fff2033e9d6 (filename not found) [in libsystem_c.dylib]
Unknown() Address = 0x7fff28470fe4 (filename not found) [in Metal]
Unknown() Address = 0x7fff2845f1b2 (filename not found) [in Metal]
Unknown() Address = 0x7fff28458f6a (filename not found) [in Metal]
Unknown() Address = 0x7fff284535db (filename not found) [in Metal]
Unknown() Address = 0x7fff28453529 (filename not found) [in Metal]
Unknown() Address = 0x7fff284497d0 (filename not found) [in Metal]
Unknown() Address = 0x7fff283d49f2 (filename not found) [in Metal]
Unknown() Address = 0x7fff284159be (filename not found) [in Metal]
mtlpp::Device::NewComputePipelineState(mtlpp::ComputePipelineDescriptor const&, mtlpp::PipelineOption, ns::AutoReleasedmtlpp::ComputePipelineReflection, ns::AutoReleasedns::Error) Address = 0x1455b48c6 (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalComputeShader::GetPipeline() Address = 0x1456e88b6 (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalStateCache::SetComputePipelineState(FMetalCommandEncoder&) Address = 0x14568ab8c (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalRenderPass::PrepareToAsyncDispatch() Address = 0x14567e61c (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalRenderPass::Dispatch(unsigned int, unsigned int, unsigned int) Address = 0x14567e05b (filename not found) [in UE4Editor-MetalRHI.dylib]
FMetalRHICommandContext::RHIDispatchComputeShader(unsigned int, unsigned int, unsigned int) Address = 0x1455edd33 (filename not found) [in UE4Editor-MetalRHI.dylib]
NiagaraEmitterInstanceBatcher::Run(FNiagaraGPUSystemTick const&, FNiagaraComputeInstanceData const*, unsigned int, unsigned int, TShaderRefBase<FNiagaraShader, FNiagaraShaderMapPointerTable> const&, FRHICommandList&, FRHIUniformBuffer*, FNiagaraGpuSpawnInfo const&, bool, unsigned int, unsigned int, FNiagaraDataInterfaceProxyRW*, bool) Address = 0x147c632d4 (filename not found) [in UE4Editor-Niagara.dylib]
NiagaraEmitterInstanceBatcher::DispatchStage(NiagaraEmitterInstanceBatcher::FDispatchInstance&, unsigned int, FRHICommandList&, FRHIUniformBuffer*) Address = 0x147c6254d (filename not found) [in UE4Editor-Niagara.dylib]
NiagaraEmitterInstanceBatcher::DispatchAllOnCompute(TArray<NiagaraEmitterInstanceBatcher::FDispatchInstance, TMemStackAllocator<0u> >&, FRHICommandList&, FRHIUniformBuffer*) Address = 0x147c64e1a (filename not found) [in UE4Editor-Niagara.dylib]
NiagaraEmitterInstanceBatcher::ExecuteAll(FRHICommandList&, FRHIUniformBuffer*, ETickStage) Address = 0x147c6a19d (filename not found) [in UE4Editor-Niagara.dylib]
NiagaraEmitterInstanceBatcher::PreInitViews(FRHICommandListImmediate&, bool) Address = 0x147c6b5e1 (filename not found) [in UE4Editor-Niagara.dylib]
FFXSystemSet::PreInitViews(FRHICommandListImmediate&, bool) Address = 0x10dd3e660 (filename not found) [in UE4Editor-Engine.dylib]
FSceneRenderer::PreVisibilityFrameSetup(FRHICommandListImmediate&) Address = 0x120b87eca (filename not found) [in UE4Editor-Renderer.dylib]
FDeferredShadingSceneRenderer::InitViews(FRHICommandListImmediate&, FExclusiveDepthStencil::Type, FILCUpdatePrimTaskData&) Address = 0x120b51e4b (filename not found) [in UE4Editor-Renderer.dylib]
FDeferredShadingSceneRenderer::Render(FRHICommandListImmediate&) Address = 0x120498b89 (filename not found) [in UE4Editor-Renderer.dylib]
RenderViewFamily_RenderThread(FRHICommandListImmediate&, FSceneRenderer*) Address = 0x120bd739a (filename not found) [in UE4Editor-Renderer.dylib]
TEnqueueUniqueRenderCommandType<FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::FDrawSceneCommandName, FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::$_45>::DoTask(ENamedThreads::Type, TRefCountPtr const&) Address = 0x120bd6b92 (filename not found) [in UE4Editor-Renderer.dylib]
TGraphTask<TEnqueueUniqueRenderCommandType<FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::FDrawSceneCommandName, FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::$_45> >::ExecuteTask(TArray<FBaseGraphTask*, TSizedDefaultAllocator<32> >&, ENamedThreads::Type) Address = 0x120bd9ada (filename not found) [in UE4Editor-Renderer.dylib]
FNamedTaskThread::ProcessTasksNamedThread(int, bool) Address = 0x109105466 (filename not found) [in UE4Editor-Core.dylib]
FNamedTaskThread::ProcessTasksUntilQuit(int) Address = 0x109103a80 (filename not found) [in UE4Editor-Core.dylib]
RenderingThreadMain(FEvent*) Address = 0x10b377aa3 (filename not found) [in UE4Editor-RenderCore.dylib]
FRenderingThread::Run() Address = 0x10b3a2407 (filename not found) [in UE4Editor-RenderCore.dylib]
FRunnableThreadPThread::Run() Address = 0x10922a3b8 (filename not found) [in UE4Editor-Core.dylib]
FRunnableThreadPThread::_ThreadProc(void*) Address = 0x1091b69a4 (filename not found) [in UE4Editor-Core.dylib]
_pthread_start Address = 0x7fff203ec950 (filename not found) [in libsystem_pthread.dylib]
thread_start Address = 0x7fff203e847b (filename not found) [in libsystem_pthread.dylib]

I have the same issues here.
Trying to run Meta Human on a MBP 16, 2020 with an Radeon graphics card.

Always crashing…any solution?

Same here, crashing on iMac when dropping meta human BP into scene.

Same here, crashing on Windows when dropping meta human BP into scene.

OK, so, I import a new Metahuman and see that the Blueprint has errors and will not compile. If I drag the BP to a map - CRASH! But, I cannot open to edit the default 01 or 04 BP without a crash. So, I think my problem is that my machine is at the bottom of the barrel of being able to run Unreal and will have to deal with this later. For now, it is enough to learn most of the engine. So, no Metahuman contest entry for me but, thanks to EPIC for letting me play with this awesome toy for no money. Love you guys!!!

It’s the same problem for me. Also think that my computer is not strong enough.
MPG B550 Gaming Plus
AMD Ryzen 5 3600X
16GB DDR4
Nvidia GTX 1050 ti

same here. :disappointed:

I’ve been running into this issue as well, UE editor crashing when dropping in the metahuman into the scene. (iMac 4K 2017, i5-7500, 32GB RAM, Radeon 560 Pro).

I managed to fix this though, and these two posts pointed me in the right direction:

I disabled hair simulations and now it works on my end.

To do this, look for the Groom Asset and disable the hair simulation.

Hope this helps!

2 Likes

Hi. For me I think it was prob a graphics card issue. I have a new laptop that has a better cpu and gpu then the mac i was using and i haven’t really had any major issues yet using at least 2 metahumans in the scene. I would be interested to know how unreal, quixel, metahumans, etc. run on the new M1 chip.

Me too, ( apple M1 2020 MacBook Pro )

Thank you phi!
Your suggestion worked for me. The hair is not as real as with - Enable Simulation On but better than nothing.

If you are on Mac do what “phi” its saying. According to unrealdoc. Strands on Mac are not supported, only Cards.

Hi, I confirm. I have Mac M1 and this is the issue with a metahuman. It is necessary to disable Hair simulation as phi suggested. Then it works without crashing. By the way, do you know how to improve the visualization quality of metahumans? It looks like LOD5-6 even if I have forced LOD0 in blueprint LOD->Forced LOD. It is not even close to what it should be in the metahuman editor online. Thanks.

Disabling the hair simulation worked also for me, thanks for sharing!

Capture
Capture2
If your standard document folder has been moved to another drive, just like mine, then you need to change the path, as shown in the screenshots above

This works. Thank you for sharing. Huge help.