Download

Unreal 5 datasmith does not start CAD impoter for Autodesk Inventor

After all datasmith plugins enable, CAD Importer not working only basic import, all extensions for CAD software missing in menu select. What is problem. Tried on UE 5 EA and last UE5 source.

Last worked ok in 4.26 (4.27 with broken reimport function).

Hello Zidekk2,
can you give more details and screen capture as we cannot repro here.

We just did a test on early access and the files are available in datasmith import window
Are you loading file through the datasmith button? Datasmith for UE5? - #2 by UE_FlavienP

After computer restart problem lost and now i see all cad extensions, im sure that problem was when i enable all datasmith plugins and only restart UE5.

in source 4.28 main problem still exists… after computer restart (i see only 3 extensions xml, plmxml and udatasmith.

Can you tell me:

  • 4.28 main does not exist. Do you mean 4.27 main? from github? which commit did you build?
  • which datasmith plugin did you activate in your test428 project? All of them?
  • can you go in the test428/Saved/Logs folder, zip and share the log files with me? At least the last one?

if you compile master branch is identified like 4.28.

all datasmith plugins enabled missing cad files

save/logs/ folder is empty…

Hello zidekk2,

Regarding the access to CAD import, I forgot that we do not share the third party SDKs needed to build some of the necessary modules (Alias, CAD, Rhino, …) in the git version. So it is normal you do not get those.

The master branch is pointing to our main UE4 branch that is not developed anymore.
You will want to use either:

  • 4.27: that is ahead of release (4.27) where fixes are added
  • ue5-main: the main branch for UE5 development.

The next problem is datasmith CAD import 3d models from Autodesk Inventor (2019,2020,2021) to new version 4.27 reimport totally not works (today I test again with 4.27.1 same problem not fixed) is there someone responsible for CAD import?
first test Inventor model


after import in unreal
image

changed lenght of autodesk model (lenght of rod)

reimport after inventor model changed

in unreal not changed anything (something is wrong in reimport function!!!) (tested with reimport with new file same problem)
image

I tested early access UE5 in this version working reimport from Inventor again OK, but it is only beta many plugins missing… currently

Hello zidekk2,

I am a bit confused as I tried 2 separate times following your comment and it was fixed on the 4.27 main branch that I thought would ship for 4.27.1.

I tried again today and it fails on 4.27.1 but works on the 4.27 main branch.
I will contact again the dev team and ask them to investigate more on that.

Thank you for chasing us and sorry for the delay.

We are still searching why the behaviour is like that.
For now, you can bypass that by deleting the folder “\Intermediate\DatasmithCADCache” in your project folder before doing a reimport.

Thanks for fast reply, I will test tomorrow this temporary solution for datasmith in 4.27.

Other problems for example metahuman bug in package export does it take month without reply… :-(.

I tried that solution but only working for first time if i remove cache. Second remove of cache and then reimport same problem like before…any change. I tried reimport from file same problem…

Hello again,

so we figure out where the problem comes from and it will be fix but for 4.27.2.
The Dev tells me you could also try with this cvar r.CADTranslator.EnableThreadedImport 1 for now.

Regarding the metahuman ticket, we have team to publish information on the forum and we have people that browse the topics to collect feedback and give answers but we do not have a dedicated team for that.

Tested in 4.27.2 bug with reimport was fixed :-), still textures not working only basic color which works for parts only, if color is setup in asm parts are only gray.